JPG attachment is truncated when message containing it is clicked on

RESOLVED WORKSFORME

Status

Thunderbird
Message Reader UI
RESOLVED WORKSFORME
6 years ago
10 months ago

People

(Reporter: Michael Rye, Unassigned)

Tracking

17 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 689003 [details]
thunderbird_after_click.jpg

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0
Build ID: 20121128204232

Steps to reproduce:

Send an HTML format message with a JPG attachment from my work account to home account.  Upon initial receipt, message size is correct.  I sent it to myself twice.  In the attached image, the one above the highlight is the original size.  The highlighted one is the size that it reduced to after simply clicking on it once.  The Don't download messages larger than ## KB setting is not activated.


Actual results:

When the message is clicked on, the message size shrinks to less than 10% of originally received size.  The message is displayed, and only the top part of the JPG image is displayed.


Expected results:

Message size should not have reduced, and the entire image should have displayed.
(Reporter)

Comment 1

6 years ago
Created attachment 689005 [details]
Respective setting window showing size limit option turned off
(Reporter)

Comment 2

6 years ago
IMAP server still shows the correct size even after clicking on it in Thunderbird.
Michael, can you try this:

Select the two messages, then right-click selection.
From context menu, choose "Get selected messages".
Does that help?
(Reporter)

Comment 4

6 years ago
Tried. Get selected messages option is greyed out.

Comment 5

6 years ago
I have the same problem. Get Selected messages is also greyed out.
(Reporter)

Comment 6

6 years ago
JPG image truncation problem also happens on my mother's computer with Thunderbird 17.0.  She just reported it to me this evening.  Not pleasant when she calls me complaining about not being able to see pictures of her grandkids that my sister sent her.
(Reporter)

Comment 7

6 years ago
Both machines running currently available ZoneAlarm free firewall and Avast anti-virus free. Auto-updates, so they stay current, on both software are turned on.

Comment 8

10 months ago
I cannot reproduce this using 52.4.0.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.