Closed Bug 818904 Opened 9 years ago Closed 9 years ago

Social Share app not installable on Mobile

Categories

(Firefox for Android Graveyard :: Web Apps (PWAs), defect)

19 Branch
All
Android
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 819103

People

(Reporter: eviljeff, Unassigned)

References

()

Details

Social Share App installs on Desktop but on Android reports it the manifest is invalid.  I can't see anything obvious and I attempted to manually download the manifest also (looking at the actual contents turned out to be too difficult but it didn't 404 and the size was the same)
User-agent detection?
(In reply to Aaron Train [:aaronmt] from comment #1)
> User-agent detection?

Possibly but its normally obvious (redirects to a 404, etc).  And changing it to Desktop with Phony doesn't seem to help either.
Summary: Social Share app uninstallable on Mobile → Social Share app installable on Mobile
Summary: Social Share app installable on Mobile → Social Share app not installable on Mobile
You should also be able to use the remote console to look at what is returned.
I just get '--[17:58:09.706] Error code: INVALID_MANIFEST'

the manifest request itself looks fairly normal also:

Request URL:
    http://divelapps.appspot.com/socialshare.webapp
    Request Method:
    GET
    Status Code:
    HTTP/1.1 200 OK
    Request Headers
    17:58:09.000
  
  User-Agent:Mozilla/5.0 (Android; Mobile; rv:19.0) Gecko/19.0 Firefox/19.0Host:divelapps.appspot.comConnection:keep-aliveCache-Control:max-age=0Accept-Language:en-US,en;q=0.5Accept-Encoding:gzip, deflateAccept:text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8

    Response Headers
    Δ258ms
  
  Server:Google FrontendDate:Thu, 06 Dec 2012 17:58:09 GMTContent-Type:application/x-web-app-manifest+json; charset=UTF-8Content-Length:400
    
      Response Body
      Δ0ms
    
    {"version": "1.0","name": "Social Share","description": "Share an URL in Google+ and Tuenti","launch_path":"/socialshare.html","icons":{"128":"http://divelapps.appspot.com/socialshare128.png"},"developer": {"name": "Adrián Arroyo Calle","url": "http://sites.google.com/site/divelmedia"},"installs_allowed_from": ["*"],"appcache_path": "/cache.manifest","fullscreen": "false","default_locale": "en"}
I know what this is! It's another dupe of the regression for the mime type.

Type:application/x-web-app-manifest+json; charset=UTF-8

Same root cause as twitter.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 819103
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.