Closed Bug 819103 Opened 8 years ago Closed 8 years ago

Twitter fails to install from Marketplace

Categories

(Core Graveyard :: DOM: Apps, defect, P1)

x86
macOS
defect

Tracking

(blocking-basecamp:+, firefox18+ fixed, firefox19+ fixed, firefox20+ fixed, b2g18 verified)

VERIFIED FIXED
B2G C2 (20nov-10dec)
blocking-basecamp +
Tracking Status
firefox18 + fixed
firefox19 + fixed
firefox20 + fixed
b2g18 --- verified

People

(Reporter: willyaranda, Assigned: fabrice)

References

()

Details

(Keywords: regression)

Attachments

(2 files)

Attached image Gaia error
E/GeckoConsole( 1439): Content JS LOG at https://marketplace.cdn.mozilla.net/media/js/mkt/consumer-min.js?build=9a3d167:16 in anonymous: Error code: INVALID_MANIFEST
D/memalloc(  768): /dev/pmem: Allocated buffer base:0x4aa00000 size:614400 offset:3072000 fd:183
D/memalloc( 1439): /dev/pmem: Mapped buffer base:0x44f4e000 size:3686400 offset:3072000 fd:44
E/GeckoConsole(  768): Content JS LOG at https://marketplace.cdn.mozilla.net/media/js/mkt/consumer-min.js?build=9a3d167:16 in anonymous: Error code: INVALID_MANIFEST


Marketplace shows an invalid url.

Also, reviews on the market shows the same: https://marketplace.firefox.com/app/twitter/
Component: Gaia → Consumer Pages
Product: Boot2Gecko → Marketplace
Version: unspecified → 1.0
Confirmed. The manifest looks right, but hmm...I wonder why it's failing. Cvan - Any thoughts?
The manifest is wellformed, and this works fine on desktop. This does not look like a Marketplace bug.
Component: Consumer Pages → Gaia
Product: Marketplace → Boot2Gecko
Version: 1.0 → unspecified
(In reply to Chris Van Wiemeersch [:cvan] from comment #2)
> The manifest is wellformed, and this works fine on desktop. This does not
> look like a Marketplace bug.

Fails for me on desktop with the 12/6 build.
Component: Gaia → DOM: Apps
Product: Boot2Gecko → Core
Spoke with Fabrice on this one - it's a bug from the mime type bug we landed.

Flip all of the tracking flags!
blocking-basecamp: --- → ?
Keywords: regression
Blocks: 741526
Attached patch patchSplinter Review
Assignee: nobody → fabrice
Attachment #689446 - Flags: review?(jonas)
blocking-basecamp: ? → +
Can you add a test for this?
Duplicate of this bug: 818904
Priority: -- → P1
Target Milestone: --- → B2G C2 (20nov-10dec)
https://hg.mozilla.org/mozilla-central/rev/76fdff965077
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Keywords: verifyme
QA Contact: jsmith
Duplicate of this bug: 820199
Whiteboard: [3rd-party-preloaded-apps]
Moving this to the tracking bug for preinstalled apps
Whiteboard: [3rd-party-preloaded-apps]
Whiteboard: [status-b2g18:fixed]
Whiteboard: [status-b2g18:fixed]
Verified on b2g-18.
Status: RESOLVED → VERIFIED
Keywords: verifyme
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.