autocomplete grabs X keyboard (breaks ALT-TAB)

RESOLVED WORKSFORME

Status

()

Core
XUL
RESOLVED WORKSFORME
17 years ago
7 years ago

People

(Reporter: robbe, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Hixie-P0])

(Reporter)

Description

17 years ago
Bug occurs in today's snapshot together with XFree86 4.0.3.

The autocomplete widget grabs the keyboard. This will interfere with a number of
things:

1. The window manager will not get keyboard shortcuts delivered to it. That
means users will not be able to switch windows, etc. during autocomplete.

2. Users with German keyboards can no longer enter @ or ~ when autocomplete
kicks in. These symbols are entered using the AltGr key, and AltGr processing
seems to be disabled while grabbing. There are other symbols affected as well,
but these are the most common in URLs and mail addresses (LDAP autocomplete!).
Users of other European keyboards will have similar problems, perhaps with
different (more or less popular) symbols.

A workaround is getting out of autocomplete mode, for example by moving the
cursor left and right.

Turning autocomplete off does NOT prevent this bug: the autocomplete box is not
shown, but the keyboard is grabbed anyway. There is now no visual indication
whether grabbing is in effect, making the effects even more mysterious.

Comment 1

17 years ago
keyboard input ruined by autocomplete in mailnews is bug 61439
(Reporter)

Updated

17 years ago
Blocks: 61439, 80240

Comment 2

17 years ago
> Turning autocomplete off does NOT prevent this bug: the autocomplete box is not
> shown, but the keyboard is grabbed anyway.

That might be a bug by itself.

Comment 3

17 years ago
Yep this is annoying. I can't Alt-Fx to switch virtual desktops in Enlightenment
for example.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: mozilla0.9.2, regression

Updated

17 years ago
Status: NEW → ASSIGNED

Comment 4

17 years ago
bug 61439 separately addresses:

  "German keyboards can no longer enter @ or ~ when autocomplete kicks in"

Comment 5

17 years ago
I'd be happiest if I could just turn off the dropdown in order to stop the focus
stealing.  Is there any way to do that?  Turning off autocomplete doesn't do it;
it just reduces the number of items in the dropdown to one instead of many.  I'd
prefer to turn off the dropdown entirely, because it's visually distracting as
well as stealing my keyboard focus.

Comment 6

17 years ago
*** Bug 85365 has been marked as a duplicate of this bug. ***

Comment 7

17 years ago
Akkana, I want the exact same thing.
Perhaps a seperate bug should be filed for that instead of mutating this one.

Comment 8

17 years ago
Filed bug 97344.

Comment 9

17 years ago
Can anyone confirm that this is still a problem?
Priority: -- → P3
Target Milestone: --- → Future

Comment 10

17 years ago
Yes, it does still occur. Tested in build pulled from the tip today on Linux.
The workaround is to simply click elsewhere then do your desired keyboard
combination to, say, switch desktops.
dup

*** This bug has been marked as a duplicate of 106707 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
woops, duped in the wrong direction
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
*** Bug 106707 has been marked as a duplicate of this bug. ***
This also occurs on Windows. -> All/All.
OS: Linux → All
Hardware: PC → All
Whiteboard: [Hixie-P0]

Comment 15

16 years ago
This is currently not fixed for Mozilla 1.1 on Linux. Very irritating (makes
full keyboard navigation impossible if you need to check something in another
window in order to finish choosing your URL!).

Comment 16

16 years ago
*** Bug 171921 has been marked as a duplicate of this bug. ***

Comment 17

15 years ago
Why don't we vote this bug??

Comment 18

14 years ago
*** Bug 237697 has been marked as a duplicate of this bug. ***

Comment 19

14 years ago
Expanding summary a bit; this would have prevented the dups from bug 237697 and
bug 171921.
Summary: autocomplete grabs X keyboard → autocomplete grabs X keyboard (breaks ALT-TAB)

Comment 20

13 years ago
This isn't just location bar (or even autocomplete).  It happens with HTML form drop-downs too.
==> XUL
Assignee: hewitt → nobody
No longer blocks: 80240
Status: REOPENED → NEW
Component: Location Bar → XP Toolkit/Widgets: XUL
Priority: P3 → --
QA Contact: claudius → xptoolkit.xul
Target Milestone: Future → ---

Comment 21

11 years ago
6 years later and still not fixed?

Comment 22

11 years ago
Please, vote this bug.

Updated

10 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: xptoolkit.xul → xptoolkit.widgets

Comment 23

9 years ago
Any news on this bug?

Comment 24

9 years ago
Another duplicate: Bug 454080

Comment 25

9 years ago
Other consequences of this bug:

- "Change desktop" (ctrl + alt + arrow) does not work (Ubuntu)
- Gnome panel: If a panel is set to Autohide, it will normally
reappear when the mouse pointer is hovering over it. This bug causes the panel
to remain hidden.
- Normal tab navigation within Firefox does not work / changes behaviour (ex: pressing tab to move from address-field to search-field)

Comment 26

9 years ago
Ubuntu Bug:
https://bugs.launchpad.net/ubuntu/+source/firefox-3.5/+bug/22199

Still occurring on 3.7 trunk.

Comment 27

9 years ago
Workaround: Press ESC (makes the dropdown go away), then Alt-Tab

Updated

8 years ago
Duplicate of this bug: 454080

Comment 29

8 years ago
> Workaround: Press ESC (makes the dropdown go away)

That is, unless Firefox is frozen. Ubuntu bug commenter says this happened to him and locked him out of X.

Comment 30

7 years ago
Tested with firefox 7.0.1 and Ubuntu Oneiric. alt-tab works as it should first try. Is anyone still having this issue?

Comment 31

7 years ago
Seems to work fine on Ubuntu 10.11. Altered tab behaviour (Comment #25) remains, but  I guess that's a different bug..

Comment 32

7 years ago
confirmed.
WORKSFORME, too, on Ubuntu with Gnome 2.
Status: NEW → RESOLVED
Last Resolved: 17 years ago7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.