Last Comment Bug 819732 - Land Telemetry enabled by default on Nightly/Aurora
: Land Telemetry enabled by default on Nightly/Aurora
Status: RESOLVED FIXED
[Telemetry]
:
Product: Toolkit
Classification: Components
Component: Telemetry (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla20
Assigned To: Lawrence Mandel [:lmandel] (use needinfo)
:
: Georg Fritzsche [:gfritzsche]
Mentors:
Depends on: 699806 701178 725987 737596 737600 823259 824647
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-08 17:24 PST by Théo Chevalier [:tchevalier]
Modified: 2013-01-11 14:56 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (1.17 KB, patch)
2012-12-08 17:30 PST, Théo Chevalier [:tchevalier]
gavin.sharp: review+
Details | Diff | Splinter Review

Description Théo Chevalier [:tchevalier] 2012-12-08 17:24:34 PST
This bug will turn on recent work about enabling by default Telemetry on Nightly/Aurora.

In order to synchronize the release with website changes, blog post, etc., please do not land the attached patch until Lawrence gives his signal.

Current states of our patches:

Desktop:
699806: landed
737600: landed

Mobile:
737600: ready to land
737596: ready to land
725987: I just asked for a final review
Comment 1 Théo Chevalier [:tchevalier] 2012-12-08 17:30:13 PST
Created attachment 690154 [details] [diff] [review]
Patch
Comment 2 Théo Chevalier [:tchevalier] 2012-12-10 14:50:57 PST
Lawrence, mobile patches has just landed.
We're good!
Comment 3 Lawrence Mandel [:lmandel] (use needinfo) 2012-12-11 14:10:08 PST
Excellent! I have been anxiously watching all of your patches receive r+ and land.
Comment 4 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-12-12 18:22:08 PST
While we're waiting, can we generate some try builds with the feature on to get a bit wider testing before flipping the switch for everyone?

Lawrence: Bug 701178 looks almost done, but I noticed that it just adds links to http://www.mozilla.org/legal/privacy/firefox.html, which hasn't been updated to mention this AFAICT. Is there a separate bug tracking that?
Comment 5 Lawrence Mandel [:lmandel] (use needinfo) 2012-12-12 18:47:53 PST
The Telemetry section of the privacy policy (Usage Statistics) was updated in the last push. I think you're referring to the line "...Firefox includes functionality that is turned off by default...", which does look like it needs to be updated. Please let me know if I have correctly identified your concern.

Jishnu - Can you comment on if the privacy policy needs to be updated before Telemetry is enabled by default on Nightly and Aurora? If so, can you push a small update to cover this change?
Comment 6 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-12-12 19:26:11 PST
(In reply to Lawrence Mandel [:lmandel] from comment #5)
> I think you're referring to the line "...Firefox includes functionality that is
> turned off by default...", which does look like it needs to be updated. Please let
> me know if I have correctly identified your concern.

Yes, that's what I was referring to.
Comment 7 Théo Chevalier [:tchevalier] 2012-12-13 00:29:10 PST
(In reply to :Gavin Sharp (use gavin@gavinsharp.com for email) from comment #4)
> While we're waiting, can we generate some try builds with the feature on to
> get a bit wider testing before flipping the switch for everyone?

Yep, https://tbpl.mozilla.org/?tree=Try&rev=9f20f0702c04
Comment 8 Lawrence Mandel [:lmandel] (use needinfo) 2012-12-19 17:13:32 PST
The Firefox privacy policy has been updated (bug 822523). We're clear to pref on Telemetry enabled-by-default on Aurora and Nightly.

Gavin - Can you provide the review for Theo's patch and get the change landed on MC?
Comment 9 Lawrence Mandel [:lmandel] (use needinfo) 2012-12-20 12:36:20 PST
The correct bug for the privacy policy update is bug 823259.
Comment 10 Théo Chevalier [:tchevalier] 2012-12-20 12:37:29 PST
That's good news, Lawrence, thanks.

I updated https://support.mozilla.org/en-US/kb/send-performance-data-improve-firefox (Still needs to be reviewed)
I added the text you created last year, updated the string to match the current opt-in string and added Linux screenshots.
(I hope that's fine, because it's my first SUMO contribution)

Also added your string here: https://support.mozilla.org/en-US/kb/how-can-i-help-submitting-mobile-performance-data 

"Telemetry is an opt-out feature on the Firefox Aurora and Firefox Nightly developer channels. This means that Firefox will collect and send this information to Mozilla by default."
Comment 11 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-12-20 12:53:13 PST
Théo, do you want to land this patch?
Comment 12 Théo Chevalier [:tchevalier] 2012-12-20 12:58:03 PST
(In reply to :Gavin Sharp (use gavin@gavinsharp.com for email) from comment #11)
> Théo, do you want to land this patch?

Sure :)
Comment 13 Théo Chevalier [:tchevalier] 2012-12-20 13:06:08 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/8d0fa262d9c0
Comment 14 :Ms2ger (⌚ UTC+1/+2) 2012-12-22 06:56:46 PST
https://hg.mozilla.org/mozilla-central/rev/8d0fa262d9c0
Comment 15 Vladan Djeric (:vladan) 2013-01-11 11:59:26 PST
idle-daily submissions more than doubled in Nightly, but only starting with the January 5 build. Maybe because of holidays?

http://tinyurl.com/aonox3v

Aurora submissions stayed the same, but that's because we didn't uplift, so it might take a few more days for any change to register:

http://tinyurl.com/abpsptj
Comment 16 Lawrence Mandel [:lmandel] (use needinfo) 2013-01-11 14:56:06 PST
(In reply to Vladan Djeric (:vladan) from comment #15)
> idle-daily submissions more than doubled in Nightly, but only starting with
> the January 5 build. Maybe because of holidays?
> 
> http://tinyurl.com/aonox3v

I think your holiday explanation is a good one. This change didn't land until Dec. 22.

> Aurora submissions stayed the same, but that's because we didn't uplift, so
> it might take a few more days for any change to register:
> 
> http://tinyurl.com/abpsptj

Yes. We should check back on Aurora next week.

Note You need to log in before you can comment on or make changes to this bug.