Closed Bug 819937 Opened 7 years ago Closed 7 years ago

B2G SMS: When an SMS of more than 160 characters is sent (that is 2 SMS) it's not sent properly

Categories

(Core :: DOM: Device Interfaces, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla21
blocking-b2g tef+
blocking-basecamp -
Tracking Status
firefox19 --- wontfix
firefox20 --- wontfix
firefox21 --- fixed
b2g18 --- fixed
b2g18-v1.0.0 --- fixed

People

(Reporter: sonmarce, Assigned: vicamo)

References

Details

Attachments

(1 file, 1 obsolete file)

STR:
1-Open SMS app
2-Write an SMS of more than 160 characters
3-Press send button
4-Close SMS app
5-Open notifications tray

Expected result --> The number of messages sent have been incremented by two.
Actual result --> The number of messages sent have been incremented by one.
The thing is that the message is not sent, so Cost Control cant count it! Vicamo it's working on it ;)
Assignee: nobody → vyang
blocking-basecamp: --- → ?
Component: Gaia::Cost Control → DOM: Device Interfaces
Product: Boot2Gecko → Core
QA Contact: carlos.martinez
Summary: [COST CONTROL] When an SMS of more than 160 characters is sent (that is 2 SMS), only one SMS is counted by the app → B2G SMS: When an SMS of more than 160 characters is sent (that is 2 SMS) it's not sent properly
This it's happening with a VIVO SIM Cards in our tests in Berlin.
(In reply to Borja Salguero [:borjasalguero] from comment #1)
> The thing is that the message is not sent, so Cost Control cant
> count it! Vicamo it's working on it ;)

Confirmed, 2 SR received, but UI still shows pending.
We have tested that with a SIM in Roaming, SMS is marked by Gecko as 'sending' and it's not updated to Sent. Between T-Mobile SIM Cards in Berlin it's working... :S!
Let's fix this for v1 but after basecamp.
blocking-b2g: --- → tef+
blocking-basecamp: ? → -
Borja, could you help verifying this patch?
Attachment #700382 - Flags: feedback?(fbsc)
Blocks: 788928
rebase to m-c/master tip
Attachment #700382 - Attachment is obsolete: true
Attachment #700382 - Flags: feedback?(fbsc)
Attachment #700401 - Flags: feedback?(fbsc)
For sure! Could you generate a Build with the patch? I will go to your seat and I will flash it!
Working!!! :):):) Awesome work Vicamo!
Attachment #700401 - Flags: feedback?(fbsc) → feedback+
Path it's working, and it's a thing to have during this week, because sending SMS properly it's a must to have in our device! bb+?
blocking-basecamp: - → ?
i'll approve the patch for the b2g18 branch.  Lets get the patch reviewed.
blocking-basecamp: ? → -
Comment on attachment 700401 [details] [diff] [review]
fix multiple sms-delivery messages sent

We are actually waiting for the last SR for delivery message. Previous changes compares 'options.segmentSeq' to 'options.segmentMaxSeq', which is always false because at the time we've sent all segments out, the two numbers are actually equal to each other.
Attachment #700401 - Flags: review?(allstars.chh)
Attachment #700401 - Flags: review?(allstars.chh) → review+
adding cert blocker...
https://hg.mozilla.org/mozilla-central/rev/16cb74a835b0
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla21
Landed on mozilla-b2g18/gaia master prior to the 1/25 branching to mozilla-b2g18_v1_0_0/v1.0.0, updating status-b2g-v1.0.0 to fixed.
You need to log in before you can comment on or make changes to this bug.