[MMI/USSD] System message on incoming USSD

RESOLVED FIXED in Firefox 19

Status

()

P1
normal
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: ferjm, Assigned: ferjm)

Tracking

Trunk
B2G C3 (12dec-1jan)
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking-basecamp:+, firefox19 fixed, firefox20 fixed, b2g18 fixed)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Assignee)

Description

6 years ago
We need to add the ability to send a system messages when an USSD message (reply for previous USSD requests or network initiated ones) is received by the RIL to notify about it when no listener is actively waiting for the 'ussdreceived' event.
(Assignee)

Comment 1

6 years ago
Nominating as bb+ for the reasons explained in Bug 815504.

Basically, not sending system messages on incoming USSD messages might cause that the user never knows about them if the communication app is not running.
blocking-basecamp: --- → ?
(Assignee)

Updated

6 years ago
Blocks: 820295
(Assignee)

Updated

6 years ago
Assignee: nobody → ferjmoreno
(Assignee)

Updated

6 years ago
Blocks: 814931
This should be blocking as responses about critical operations such as top-ups may be missed if we don't fix it.
Blocking and P1 based on comment #2.
blocking-basecamp: ? → +
Priority: -- → P1
Target Milestone: --- → B2G C3 (12dec-1jan)
(Assignee)

Comment 4

6 years ago
Created attachment 692280 [details] [diff] [review]
WIP

I'd like to do some tests before asking for r?
(Assignee)

Comment 5

6 years ago
Created attachment 692353 [details] [diff] [review]
v1
Attachment #692280 - Attachment is obsolete: true
Attachment #692353 - Flags: review?(philipp)
(Assignee)

Comment 6

6 years ago
Created attachment 692356 [details] [diff] [review]
Gaia test (won't be submitted)

I've tested the platform patch with this Gaia test
Attachment #692353 - Flags: review?(philipp) → review+

Comment 8

6 years ago
https://hg.mozilla.org/mozilla-central/rev/a80379c23cff
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
https://hg.mozilla.org/releases/mozilla-aurora/rev/c6671a6c7915
https://hg.mozilla.org/releases/mozilla-b2g18/rev/506067fc8d50
status-b2g18: --- → fixed
status-firefox19: --- → fixed
status-firefox20: --- → fixed

Updated

6 years ago
Duplicate of this bug: 814931
You need to log in before you can comment on or make changes to this bug.