Test failure "Timeout exceeded for waitForElement Selector: *[label='Test Bookmark 1']" in endurance/testBookmarks_OpenAndClose/test1.js

RESOLVED FIXED

Status

Mozilla QA
Mozmill Tests
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: AndreeaMatei, Assigned: Daniela Petrovici)

Tracking

unspecified
x86
Linux

Firefox Tracking Flags

(firefox-esr10 fixed)

Details

(Whiteboard: [mozmill-test-failure][endurance], URL)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
This happened today on Linux x86, with ESR10, en-US locale.
Could be a regression from bug 812438, that was landed yesterday?
(Reporter)

Updated

5 years ago
status-firefox-esr10: --- → affected
Whiteboard: [mozmill-test-failure][endurance]
(Assignee)

Comment 1

5 years ago
It's a regression. Will work on a fix today
(Assignee)

Comment 2

5 years ago
Created attachment 690889 [details] [diff] [review]
patch v1.0

The waitThenClick(testFolder) did not work on Ubuntu with ESR10

I changed to waitForElement and left mouseDown and mouseUp as it was before the change from bug 812438.

Reports for all platforms are below:
http://mozmill-crowd.blargon7.com/#/endurance/report/a11aa7b15f4e571fd6fe21a2db02a0ae
http://mozmill-crowd.blargon7.com/#/endurance/report/a11aa7b15f4e571fd6fe21a2db0386dc
http://mozmill-crowd.blargon7.com/#/endurance/report/a11aa7b15f4e571fd6fe21a2db0759eb
Assignee: nobody → dpetrovici
Status: NEW → ASSIGNED
Attachment #690889 - Flags: review?(hskupin)
Attachment #690889 - Flags: review?(dave.hunt)
Attachment #690889 - Flags: review?(andreea.matei)
(Reporter)

Updated

5 years ago
Depends on: 812438
(Reporter)

Comment 3

5 years ago
Comment on attachment 690889 [details] [diff] [review]
patch v1.0

Review of attachment 690889 [details] [diff] [review]:
-----------------------------------------------------------------

Since the change you're making here is backing out the patch in bug 812438, we're going to backout that one and proceed there with a follow up fix.
Attachment #690889 - Flags: review?(hskupin)
Attachment #690889 - Flags: review?(dave.hunt)
Attachment #690889 - Flags: review?(andreea.matei)
Attachment #690889 - Flags: review-
Fixed by the backout on bug 812438.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
status-firefox-esr10: affected → fixed
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.