Closed Bug 812438 Opened 7 years ago Closed 7 years ago

Test failure ": could not find element Selector: .bookmark-item[label='testFolder']" in endurance/testBookmarks_OpenAndClose/test1.js

Categories

(Mozilla QA Graveyard :: Mozmill Tests, defect, P2)

x86_64
macOS
defect

Tracking

(firefox-esr10 fixed)

RESOLVED FIXED
Tracking Status
firefox-esr10 --- fixed

People

(Reporter: AndreeaMatei, Assigned: daniela.p98911)

References

()

Details

(Whiteboard: [mozmill-test-failure][mozmill-endurance] s=121126 u=failure c=addons p=1)

Attachments

(2 files, 1 obsolete file)

This happened yesterday once, on OS X 10.7.5, with ESR10 en-US.
Whiteboard: [mozmill-test-failure]
Have any more failures happened here?
Priority: -- → P2
Whiteboard: [mozmill-test-failure] → [mozmill-test-failure][mozmill-endurance]
Whiteboard: [mozmill-test-failure][mozmill-endurance] → [mozmill-test-failure][mozmill-endurance] s=121126 u=failure c=addons p=1
Assignee: nobody → alex.lakatos
Status: NEW → ASSIGNED
Happened in 11/30 on ESR10 with Mac OS X 10.8.2 (x86_64):
http://mozmill-ci.blargon7.com/#/endurance/report/352218d7e3125c857fc1d3716745fadf
The previous report should be in bug 782661:
This has occurred again today(11/30): http://mozmill-ci.blargon7.com/#/endurance/report/352218d7e3125c857fc1d3716745fadf

This issue reproduces only on ESR10
Assignee: alex.lakatos → dpetrovici
Attached patch patch v1.0 (obsolete) — Splinter Review
Added the fix and changed mouseDown and mouseUp with waitThenClick for mozilla-esr10 branch as it is on Aurora and default branches for endurance/testBookmarks_OpenAndClose/test1.js
Attachment #689731 - Flags: review?(hskupin)
Attachment #689731 - Flags: review?(dave.hunt)
Attachment #689731 - Flags: review?(andreea.matei)
Attached patch patch v1.1Splinter Review
Corrected wrong commit message
Attachment #689731 - Attachment is obsolete: true
Attachment #689731 - Flags: review?(hskupin)
Attachment #689731 - Flags: review?(dave.hunt)
Attachment #689731 - Flags: review?(andreea.matei)
Attachment #689734 - Flags: review?(hskupin)
Attachment #689734 - Flags: review?(dave.hunt)
Attachment #689734 - Flags: review?(andreea.matei)
Daniela, can you please post reports showing this fix works as expected?
Thanks.
(In reply to Andreea Matei [:AndreeaMatei] from comment #9)
> Daniela, can you please post reports showing this fix works as expected?
> Thanks.

This is the report:
http://mozmill-crowd.blargon7.com/#/endurance/report/352218d7e3125c857fc1d37167ef45a3
Attachment #689734 - Flags: review?(hskupin)
Attachment #689734 - Flags: review?(dave.hunt)
Attachment #689734 - Flags: review?(andreea.matei)
Attachment #689734 - Flags: review+
http://hg.mozilla.org/qa/mozmill-tests/rev/906f8dfed9c8 (esr10)
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Blocks: 820341
Henrik or Dave, can you please backout this patch since it caused a regression?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attached patch patch v2.0Splinter Review
Added new patch with waitForElement(testFolder)
Report on Ubuntu x86:
http://mozmill-crowd.blargon7.com/#/endurance/report/a11aa7b15f4e571fd6fe21a2db68ace1
Report on Mac OS 10.7.5 x86_64:
http://mozmill-crowd.blargon7.com/#/endurance/report/a11aa7b15f4e571fd6fe21a2db68b31d
Report on Windows XP:
http://mozmill-crowd.blargon7.com/#/endurance/report/a11aa7b15f4e571fd6fe21a2db68b5a8
Attachment #692893 - Flags: review?(hskupin)
Attachment #692893 - Flags: review?(dave.hunt)
Attachment #692893 - Flags: review?(andreea.matei)
Comment on attachment 692893 [details] [diff] [review]
patch v2.0

Review of attachment 692893 [details] [diff] [review]:
-----------------------------------------------------------------

Seems to work for me on OS X, heavy loaded.
Thanks Daniela.
Attachment #692893 - Flags: review?(hskupin)
Attachment #692893 - Flags: review?(dave.hunt)
Attachment #692893 - Flags: review?(andreea.matei)
Attachment #692893 - Flags: review+
Keywords: checkin-needed
http://hg.mozilla.org/qa/mozmill-tests/rev/e057b650002f (esr10)
Status: ASSIGNED → RESOLVED
Closed: 7 years ago7 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Product: Mozilla QA → Mozilla QA Graveyard
You need to log in before you can comment on or make changes to this bug.