[COST CONTROL] Data Usage UI crashes when changing date to a previous date

RESOLVED FIXED

Status

Firefox OS
Gaia::Cost Control
--
major
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: sonmarce, Assigned: salva)

Tracking

unspecified
All
Gonk (Firefox OS)
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:tef+, b2g18 fixed, b2g18-v1.0.1 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
STR:
1-Pull down notification tray
2-Tap in the data usage module
3-Tap in the wheel to enter settings
4-Stablish yesterday as the beginning of the billing cycle 
5-Change date to the day before yesterday (with adb shell date -s yyyymmdd.hhmmss)

Expected result --> Graphic and data usage module changes accordingly to the date, as you have change of billing cycle, data from previous billing cycle should be shown if available, or nothing

Actual result --> Data usage module shows data consumption from the billing cycle corresponding to the date before any change (real today), and graphic in data usage details shows no data (and no graphic in fact)
The problem is actually part of a more general affecting any change of the date to a previous one so rewording.

Nominating to tef? because if not, the applications is not able to return to a stable state. But if it lands, despite the information could be inaccurate, at least the UI does not crash and it's able to return to a stable situation after fixing the date.
Assignee: nobody → salva
blocking-b2g: --- → tef?
Summary: [COST CONTROL] When changing date to a previous date that takes you to the previous billing period, data usage module crashes → [COST CONTROL] Data Usage UI crashes when changing date to a previous date
blocking-b2g: tef? → ---
blocking-b2g: --- → tef?
tracking-b2g18: --- → ?
(Just trying to assess the tef? here, does this only occur when the device date is moved backwards either by |adb shell| or perhaps NITZ while the cost control app is active?)
I was trying and it happen in both situations.
Created attachment 724595 [details]
Avoiding UI crash when changing the date to a previous date

This patch does not define a correct behavior for these situations, only prevent UI from crashing.
Attachment #724595 - Flags: review?(francisco.jordano)
(patch looks low risk and of course would be nice to avoid the UI crashing in this case, so assuming the patch it doesn't grow in scope/risk on review then tef+.  If needed, let's raise another bug for doing more than avoiding the UI crash so we can potentially get a better fix in v1.1 or beyond)
blocking-b2g: tef? → tef+
status-b2g18: --- → affected
status-b2g18-v1.0.1: --- → affected
tracking-b2g18: ? → ---
(In reply to Michael Vines [:m1] [:evilmachines] from comment #5)
> If needed, let's raise another bug for doing more than avoiding
> the UI crash so we can potentially get a better fix in v1.1 or beyond)

Hi, it is just what we did in bug 838556
See Also: → bug 838556
Comment on attachment 724595 [details]
Avoiding UI crash when changing the date to a previous date

r+ working well, great job as always Salva.
Attachment #724595 - Flags: review?(francisco.jordano) → review+
Master: 00f2a15d8995a12284f7038462249f819a8966cd
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
v1-train: 3b4626d5e2c58b9c5647cbd76264ae787cc2a38c

There are fairly large merge conflicts on v1.0.1.  Try doing this:

  git checkout v1.0.1
  git cherry-pick 3b4626d5e2c58b9c5647cbd76264ae787cc2a38c
  <resolve merge conflicts>
  git commit
Flags: needinfo?(salva)
This bug has a dependency on bug 841321. I got apply this one without the dependency but what do you want me to do? Consider including bug 841321 as well, please.
Flags: needinfo?(salva)
Flags: needinfo?(jhford)
(In reply to Salvador de la Puente González [:salva] from comment #10)
> This bug has a dependency on bug 841321. I got apply this one without the
> dependency but what do you want me to do? Consider including bug 841321 as
> well, please.

If bug 841321 is truly a blocker (I'm very skeptical), then you need to set blocking-b2g:tef? on that bug with an explanation. If it's not, please prepare a patch that will apply cleanly to v1.0.1 specifically.
Flags: needinfo?(jhford) → needinfo?(salva)
Depends on: 841321
I'm nominating the bug 841321 as tef?

If not passing the triage, I have a patch ready to be merged cleanly with 1.0.1
Flags: needinfo?(salva)
Bug 841321 has been marked as tef+, once it is merged, this will apply cleanly.
v1.0.1: 8c9339d5e0420132811b7e7d42424a1f64979bdc
status-b2g18: affected → fixed
status-b2g18-v1.0.1: affected → fixed

Comment 15

5 years ago
The issue is still found on v1.0.1 but not fixed for v1.1. 

The data usage for wifi shows a huge negative number when we change the date to 3/30/2013 (later date). 

Issues repros on 
Unagi Build ID: 20130329070203
Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/56c922308fd1
Gaia: 0a9f78bffafda93a159c1f502e8b110c2f49a500
status-b2g18: fixed → verified

Comment 16

5 years ago
The issue should be covered by test case:
https://moztrap.mozilla.org/manage/cases/?filter-id=6910
Flags: in-moztrap+

Comment 17

5 years ago
Sorry, I wanted comment saying the issue is NOT found on v1.0.1 but Found in v1.1 when I tried to repro this issue on build 20130329070203.

Updated

5 years ago
status-b2g18: verified → fixed
status-b2g18-v1.0.1: fixed → verified
You need to log in before you can comment on or make changes to this bug.