[toolbox] Buttons are unresponsive after previously closing the Developer Tools Window

VERIFIED FIXED in Firefox 20

Status

DevTools
Framework
P1
normal
VERIFIED FIXED
6 years ago
4 days ago

People

(Reporter: alindeac, Assigned: jwalker)

Tracking

Trunk
Firefox 20
x86
All

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed-in-fxteam])

Attachments

(1 attachment)

Mozilla/5.0 (X11; Linux i686; rv:20.0) Gecko/20121211 Firefox/20.0
Build ID: 20121211030855

Steps to reproduce:
1. Launch Firefox
2. Tools menu -> Web Developer -> Toggle Toolbox
3. Undock the window
4. Click on the Tilt button 
5. Click on the Scratchpad button
6. Click on the Responsive mode button
7. Close the Developer Tools window
8. Open the Developer Tools windows again (Tools menu -> Web Developer -> Toggle Toolbox)
9. Click on the Tilt, Scratchpad and Responsive mode buttons again.

Expected results:
Tilt, Scratchpad and Responsive mode tools are opened.

Actual results:
The buttons are unresponsive and I get the following errors in the terminal:
TypeError
  - prototype TypeError
    - columnNumber = 4
    - fileName = resource://gre/modules/devtools/Tilt.jsm
    - lineNumber = 209
  - prototype Error
  - prototype Object
error
TypeError
  - prototype TypeError
    - columnNumber = 4
    - fileName = resource://gre/modules/devtools/CmdScratchpad.jsm
    - lineNumber = 19
  - prototype Error
  - prototype Object
error
TypeError
  - prototype TypeError
    - columnNumber = 0
    - fileName = resource://gre/modules/devtools/CmdResize.jsm
    - lineNumber = 61
  - prototype Error
  - prototype Object

After I get these errors I can no longer open Tilt, Scratchpad or Responsive mode again on Firefox (regardless if I restart Firefox or dock/undock the window).

Note: So far I only reproduced this issue on Ubuntu 12.10. I will verify this also on Mac OS X and Windows and change the OS field if needed.

Updated

6 years ago
Blocks: 816946
This is reproducible also on Windows 7 and on Mac OS X 10.8.2.
OS: Linux → All

Updated

6 years ago
Priority: -- → P1
Duplicate of this bug: 821346
Assignee: nobody → jwalker
Component: Developer Tools → Developer Tools: Framework
I looked into this, and I think the problem is that commands get an environment which includes a reference to a chromeWindow. When a devtools window is *created* undocked (i.e. not created docked, and then undocked) then the reference that it gets is the window that it lives in, in which there is no gBrowser.

Patch soon.
Whiteboard: [has-patch]

Updated

6 years ago
Attachment #697486 - Flags: review?(paul) → review+

Updated

6 years ago
Whiteboard: [has-patch] → [land-in-fx-team]
Whiteboard: [land-in-fx-team] → [fixed-in-fxteam]
https://hg.mozilla.org/mozilla-central/rev/a2754cd8e66b
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 20
Verified as fixed on the latest Nightly and Aurora - the buttons work properly after previously closing the Developer Tools Window.

Verified on Windows 7, Ubuntu 12.10 and Mac OS X 10.8.2:
Mozilla/5.0 (Windows NT 6.1; rv:21.0) Gecko/20130210 Firefox/21.0 (20130210031150)
Mozilla/5.0 (Windows NT 6.1; rv:20.0) Gecko/20130210 Firefox/20.0 (20130210042017)

Mozilla/5.0 (X11; Linux i686; rv:21.0) Gecko/20130211 Firefox/21.0 (20130211031055)
Mozilla/5.0 (X11; Linux i686; rv:20.0) Gecko/20130210 Firefox/20.0 (20130210042017)

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:21.0) Gecko/20130211 Firefox/21.0 (20130211031055)
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:20.0) Gecko/20130211 Firefox/20.0 (20130211042016)
Status: RESOLVED → VERIFIED

Updated

4 days ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.