a social provider image may make the toolbar larger

RESOLVED FIXED in Firefox 20

Status

()

Firefox
SocialAPI
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: markh, Assigned: markh)

Tracking

Trunk
Firefox 20
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
The test yammer provider appears to be using an icon larger than we expect.  When you enable yammer the toolbar grows in height to fit the image.  When you switch back to facebook the toolbar shrinks back to its correct size.

Note we should not consider this a bug with the yammer provider - we should arrange for the image to be resized (or possibly cropped) regardless of the original size supplied by the provider.
(Assignee)

Comment 1

5 years ago
Created attachment 693249 [details] [diff] [review]
Use list-style-image for the provider image

It looks like list-style-image should be used for the provider image too, along with -moz-image-region.  I'm not sure about the gnomestripe change - I suspect this change will make the nearby rule:

 #social-provider-button > image {
   margin: 5px 3px;
 }

not work as intended with this change.
Assignee: nobody → mhammond
Attachment #693249 - Flags: feedback?(jaws)
Comment on attachment 693249 [details] [diff] [review]
Use list-style-image for the provider image

Review of attachment 693249 [details] [diff] [review]:
-----------------------------------------------------------------

Yeah, this should work. I'm not worried about that other rule.
Attachment #693249 - Flags: feedback?(jaws) → review+
(Assignee)

Comment 3

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/73f36736a1ae
OS: Windows 7 → All
Hardware: x86_64 → All

Comment 4

5 years ago
https://hg.mozilla.org/mozilla-central/rev/73f36736a1ae
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 20
You need to log in before you can comment on or make changes to this bug.