All users were logged out of Bugzilla on October 13th, 2018

[FTE] No counter of PIN attempts

VERIFIED FIXED in B2G C3 (12dec-1jan)

Status

P1
normal
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: askeing, Assigned: mbudzynski)

Tracking

({late-l10n})

unspecified
B2G C3 (12dec-1jan)
All
Gonk (Firefox OS)
late-l10n
Dependency tree / graph

Firefox Tracking Flags

(blocking-basecamp:+)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Tested with unagi_2012-12-11_eng.zip. 

In the FTU app, the PIN lock interface does not have counter of PIN attempts.
It should be important.

Thanks.

ref:
Bug 818172
(Reporter)

Comment 1

6 years ago
It should be a P1 blocking issue as well.
blocking-basecamp: --- → ?
OS: Windows 7 → Gonk (Firefox OS)
Hardware: x86_64 → All
(Reporter)

Updated

6 years ago
Summary: [FTU] No counter of PIN attempts → [FTE] No counter of PIN attempts
Is showing PIN attempts within v1 feature scope?
Flags: needinfo?(clee)
adding Peter to see if he can also provide a response
Flags: needinfo?(pdolanjski)
Flags: needinfo?(dcoloma)
This was considered a blocker for the "regular" switch-on (without FTE) in bug 820711 so I think this should be a blocker as the problem is the same.
Flags: needinfo?(dcoloma)

Comment 5

6 years ago
Agree, we should be consistent here with the normal PIN lock.  Let's mark bb+.
Flags: needinfo?(clee)
blocking-basecamp: ? → +
Priority: -- → P1
Flags: needinfo?(pdolanjski)
Assignee: nobody → fbsc

Updated

6 years ago
Target Milestone: --- → B2G C3 (12dec-1jan)
Assignee: fbsc → fernando.campo
(Assignee)

Updated

6 years ago
Assignee: fernando.campo → mbudzynski
(Assignee)

Comment 6

6 years ago
Created attachment 693579 [details]
patch
Attachment #693579 - Flags: review?(fernando.campo)

Updated

6 years ago
Blocks: 819528
Comment on attachment 693579 [details]
patch

Sorry, can't approve until regression issues are solved (comments in github). Please rebase and fix them, and update the pull request :)
Attachment #693579 - Flags: review?(fernando.campo) → review-
(Assignee)

Updated

6 years ago
Attachment #693579 - Flags: review- → review?(fernando.campo)
(Assignee)

Comment 8

6 years ago
Patch fixed - changes before were based on commit from 15/12, my fault.
(Assignee)

Updated

6 years ago
Keywords: late-l10n
(Assignee)

Updated

6 years ago
Attachment #693579 - Flags: review?(stas)
(Assignee)

Comment 9

6 years ago
[:fcampo] conflict resolved.
Comment on attachment 693579 [details]
patch

Is the current wording "The PIN was incorrect." correct?  I'm not a native speaker, so it's hard for me to judge.

In any case, this looks good l10n-wise. r=me.
Attachment #693579 - Flags: review?(stas) → review+
(Assignee)

Updated

6 years ago
Blocks: 823581
Attachment #693579 - Flags: review?(fernando.campo) → review+
Before merging there is a little typo in the code. a = that should be - to fix before landing ;)
(Assignee)

Comment 12

6 years ago
fixed
Merging https://github.com/mozilla-b2g/gaia/commit/54d7c73ca99dff3fd2efae1552152d4f1434342b

Sorry for not waiting for you to do it michalbe, but need it merged asap to avoid conflicts on the next PR
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Reporter)

Comment 14

6 years ago
device: unagi
build: unagi_2012-12-24 from https://releases.mozilla.com/b2g/

Verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.