Closed Bug 820922 Opened 9 years ago Closed 9 years ago

selectionsummaries.js is broken due to turning off javascript.options.xml.chrome - remove use of E4X in the file

Categories

(Thunderbird :: Mail Window Front End, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 759422

People

(Reporter: standard8, Unassigned)

References

Details

Bug 788290 has turned off e4x in chrome, and so selectionsummaries.js is broken and breaks Thunderbird on startup.

The issue being the parts that go like:

      let msgContents = <div class="row">
                          <div class="star"/>
...
I've temporarily re-enabled e4x whilst we recover from other bustage, and to stop Thunderbird being totally broken on startup:

https://hg.mozilla.org/comm-central/rev/bef92f7373a5
autoconfig was probably broken too; mailnews/base/prefs/content/accountcreation/readFromXML.js uses E4X.
Fix is on bug 759422.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 759422
You need to log in before you can comment on or make changes to this bug.