Closed Bug 821215 Opened 9 years ago Closed 3 years ago

When forwarding html+plaintext msg as plaintext (and original has <font size="xx"> in HTML part, and missing space in text/plain part), seemingly random spaces are deleted between words

Categories

(Thunderbird :: Message Compose Window, defect)

17 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: r.limanowski, Unassigned)

References

Details

(Keywords: reproducible, testcase, Whiteboard: [dupme?])

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0
Build ID: 20121128204232

Steps to reproduce:

I forwarded a message


Actual results:

the quoted content changed fro "už bendradarbiavimą" to "užbendradarbiavimą"


Expected results:

the quoted content should not get changed
STR

1 Open testcase attachment 691724 [details] in HTML view
2 verify there's a space between "už bendradarbiavimą"
3 Hold Shift while clicking "Forward" inline to forward in non-default plaintext
4 check for the space again (repeat step 2)

Actual result

After 3, space is removed from forwarded msg, so it's now "užbendradarbiavimą" which is a wrong quotation

Expected result

Don't remove spaces when forwarding as plaintext inline

Analysis/suspected causes:

1) Source of testcase attachment 691724 [details] has symptoms of pita Bug 812638: loads of interspersed useless <font size="-1"> tags, also between "už" and "bendradarbiavimą"
2) Source of text/plain; part is already lacking the space; but I don't think it would be correct behaviour to use the plaintext part when forwarding the *text/html* part as plaintext (and I'm not sure if that is what happens, and don't want to test right now)
3) I'm not sure if 1) and 2) are related, but they might be. Otherwise, this might be a dupe of existing space-eating bugs.
Depends on: font_size_bloat
Summary: message content changed while forwarding → When forwarding html+plaintext msg as plaintext (and original has <font size="xx"> in HTML part, and missing space in text/plain part), seemingly random spaces are deleted between words
Whiteboard: [dupme?]
Status: UNCONFIRMED → NEW
Ever confirmed: true
Component: Untriaged → Message Compose Window
See also bug 793527
(In reply to Onno Ekker from comment #3)
> Dupe of bug 823523?

Very possible.

Onno, could you check with testcase of this bug, if it also happens when forwarding inline in *HTML* format? (Comment 1 introduced sending in non-default plaintext format as a step to this bug, not sure why.)
When you view the testcase's source, you can see that it's multipart/alternative and the text/plain part already shows the message without the space.

The same holds when I forward the message in HTML format: When viewed as HTML the message looks good, when viewed as Plain text the spacve is missing.
Is this specific to forwarding in the mail client?  Can anyone reproduce in, e.g., <http://www-archive.mozilla.org/editor/midasdemo/>?
Also, can anyone reproduce in Thunderbird 24?  It sounds like this might be triggered somehow by bug 812638, which should be fixed now.
Richard reports this problem is gone.
Thanks Richard.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.