Unnecessary slug errors: "Changing this document's slug requires moving it and its children."

RESOLVED FIXED

Status

Mozilla Developer Network
Editing
P3
major
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: ghost@ethertank.jp, Unassigned)

Tracking

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.97 Safari/537.11

Steps to reproduce:

I've tried to save the following pages:
 https://developer.mozilla.org/ja/docs/WebGL
 https://developer.mozilla.org/ja/docs/User:ethertank


Actual results:

I failed to save. Then, the following error message is displayed:
  "Changing this document's slug requires moving it and its children."

I am not edit the slug. Slug input field does not exist now.


Expected results:

Please be able to save.
(Reporter)

Updated

4 years ago
Summary: Slug unnecessary errors: "Changing this document's slug requires moving it and its children." → Unnecessary slug errors: "Changing this document's slug requires moving it and its children."
(Reporter)

Comment 1

4 years ago
This page have same problem: https://developer.mozilla.org/ja/docs/XPIDL
I've got the error on https://developer.mozilla.org/ja/docs/Apps/Tutorials/General$edit
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Updated

4 years ago
Severity: normal → major
Priority: -- → P3
(Reporter)

Comment 3

4 years ago
https://developer.mozilla.org/ja/docs/SVG
https://developer.mozilla.org/ja/docs/CSS

Although it is not sure,
this problem seems occurred in only under "/docs/".

Previously I was able to edit these pages.
This bug is a bug that was recently added.
Please see the edit history.
(Reporter)

Comment 4

4 years ago
https://developer.mozilla.org/ja/docs/JavaScript_typed_arrays
The issue happens not only on root pages. I cannot update a link on this page:
https://developer.mozilla.org/ja/docs/Apps/Tutorials/General$edit

Comment 6

4 years ago
https://developer.mozilla.org/zh-CN/docs/DOM/XMLHttpRequest/FormData$edit
Looks like we may still have some glitches in the code following the implementation of page move support then; this happened on all pages that had subpages the first time we landed page moving, so we had to back it out.

James/David -- do we need to yank it again, or do you guys have some idea why this might be happening?
(Reporter)

Comment 8

4 years ago
https://developer.mozilla.org/ja/docs/JavaScript/Reference/Global_Objects/Array

Comment 9

4 years ago
    * This document was modified while you were editing it.

Please review the differences between your changes and the changes saved since you started editing. You may save again, but try to resolve any conflicts by hand so that the changes made since you started are not lost.
Your Changes

Revision 343247 by ziyunfei on December 28, 2012 8:03:07 PM PST
Current Revision:

Revision 343249 by ziyunfei on December 28, 2012 8:04:20 PM PST
-----------------------------------------------------------------------------
https://developer.mozilla.org/en-US/docs/JavaScript/ECMAScript_6_support_in_Mozilla$edit

Comment 10

4 years ago
https://developer.mozilla.org/zh-CN/docs/Mozilla/Firefox_OS/Platform$edit
Looks like this has been resolved by Bug 819829. I can now edit these translations:
https://developer.mozilla.org/ja/docs/Apps/Tutorials/General
https://developer.mozilla.org/ja/docs/Apps/Apps_JavaScript_API
https://developer.mozilla.org/ja/docs/WebGL
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Depends on: 840092
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.