Last Comment Bug 821914 - Unable to post or save a draft to Newsgroups
: Unable to post or save a draft to Newsgroups
Status: VERIFIED FIXED
:
Product: MailNews Core
Classification: Components
Component: Networking: NNTP (show other bugs)
: Trunk
: All All
: -- major (vote)
: Thunderbird 20.0
Assigned To: Karsten Düsterloh
:
Mentors:
: 821987 (view as bug list)
Depends on:
Blocks: 832760
  Show dependency treegraph
 
Reported: 2012-12-14 15:48 PST by Joe Sabash [:JoeS1]
Modified: 2013-01-20 09:02 PST (History)
15 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
nntplog (1.92 KB, text/plain)
2012-12-15 14:50 PST, Joe Sabash [:JoeS1]
no flags Details
fix v0 (1.92 KB, patch)
2012-12-19 12:04 PST, Karsten Düsterloh
irving: review+
Details | Diff | Splinter Review

Description Joe Sabash [:JoeS1] 2012-12-14 15:48:29 PST
Steps:
Attempt to post to news.mozilla.org

Error popup
Please verify that your mail and newsgroup setting are correct.

Error console:
    Timestamp: 12/14/2012 6:05:52 PM
    Error: GenericSendMessage FAILED: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIMsgCompose.SendMsg]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://messenger/content/messengercompose/MsgComposeCommands.js :: GenericSendMessage :: line 2909"  data: no]
    Source File: chrome://messenger/content/messengercompose/MsgComposeCommands.js
    Line: 2912

This is with Daily as of the 13th
Comment 1 Joe Sabash [:JoeS1] 2012-12-14 16:15:20 PST
Another error from a Mozillazine reporter:
    Timestamp: 12/14/2012 11:28:03 AM
    Error: [Exception... "'TypeError: (intermediate value).Count is not a function' when calling method: [nsIRunnable::run]"  nsresult: "0x8057001c (NS_ERROR_XPC_JS_THREW_JS_OBJECT)"  location: "native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0"  data: no]
Comment 2 WaltS48 2012-12-14 16:57:20 PST
I think the Platform should be all since I am a Linux user.

Mozilla/5.0 (X11; Linux i686 on x86_64; rv:20.0) Gecko/20100101 Thunderbird/20.0a1

BuildID: 20121214030351
Comment 3 Richard Marti (:Paenglab) 2012-12-15 04:53:34 PST
*** Bug 821987 has been marked as a duplicate of this bug. ***
Comment 4 Richard Marti (:Paenglab) 2012-12-15 04:56:53 PST
I saw also a report in a German newsgroup there SM is also affected (but no error showing in console).
Comment 5 Joshua Cranmer [:jcranmer] 2012-12-15 13:32:27 PST
Any NNTP logs?
Comment 6 Joe Sabash [:JoeS1] 2012-12-15 14:41:15 PST
(In reply to Joshua Cranmer [:jcranmer] from comment #5)
> Any NNTP logs?

No, but my feeling here is that we never get to the transition from composition to the actual nntp protocol. It's very similar to if you select the wrong identity and try to post. I can get logs if you really need them.
Comment 7 Joe Sabash [:JoeS1] 2012-12-15 14:50:19 PST
Created attachment 692658 [details]
nntplog

We never attempt to actually send via nntp
Comment 8 Joe Sabash [:JoeS1] 2012-12-15 15:16:34 PST
So..if you key in the exact newsgroup url:
news://mozilla.org:119/mozilla.test
The message posts just fine.
Comment 9 Florian J. [:FeuerFliege] 2012-12-18 12:54:53 PST
Regression from bug 820377 ?
Comment 10 Karsten Düsterloh 2012-12-19 12:04:12 PST
Created attachment 693990 [details] [diff] [review]
fix v0

This was broken in 2007 by bug 379070 — the funny question is which devious workaround it was hidden by for all these years … :-/
Comment 11 :Irving Reid (No longer working on Firefox) 2012-12-19 12:50:32 PST
Comment on attachment 693990 [details] [diff] [review]
fix v0

Review of attachment 693990 [details] [diff] [review]:
-----------------------------------------------------------------

I agree that it would be interesting to know what change uncovered this broken code; that said, it looks right and does the right thing when I test it.
Comment 12 Hartmut Figge 2012-12-19 13:20:51 PST
(In reply to Karsten Düsterloh from comment #10)
> Created attachment 693990 [details] [diff] [review]
> fix v0

That solves the problem for my SM 2.17a1 on Linux x86_64
Comment 13 Karsten Düsterloh 2012-12-20 07:04:15 PST
https://hg.mozilla.org/comm-central/rev/95509c6b8032
Comment 14 Joe Sabash [:JoeS1] 2012-12-20 11:07:49 PST
verified fixed with tinderbox build
http://hg.mozilla.org/mozilla-central/rev/72ed04aaae1a

Thanks Karsten
Comment 15 Alfred Peters 2012-12-29 03:50:45 PST
(In reply to Karsten Düsterloh from comment #10)
> Created attachment 693990 [details] [diff] [review]
> fix v0

In general it does works quite well.

But I still get the message when an autosave event occurs while I edit the newsgroup header (e.g. a second one).

If the Group is spelled correctly all works fine again.

New Bug?
Comment 16 :Irving Reid (No longer working on Firefox) 2013-01-08 13:09:08 PST
(In reply to Alfred Peters from comment #15)

> But I still get the message when an autosave event occurs while I edit the
> newsgroup header (e.g. a second one).
> 
> If the Group is spelled correctly all works fine again.
> 
> New Bug?

Yes, new bug please.
Comment 17 Alfred Peters 2013-01-20 09:02:21 PST
(In reply to Irving Reid (:irving) from comment #16)
> (In reply to Alfred Peters from comment #15)

> > New Bug?
> 
> Yes, new bug please.

Done: Bug 832760

Note You need to log in before you can comment on or make changes to this bug.