Front-end tests for identity on b2g

RESOLVED FIXED

Status

()

--
enhancement
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: jedp, Assigned: jedp)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [LOE:M])

We should have automated front-end tests on CI that exercise the navigator.id methods through the Persona dialog as presented in the Trusty UI on gecko.

To accomplish this, I believe three things are required, in three separate code bases, which we can track with this bug:

1. [gecko] a way to allow synthetic events by pref (see Bug 822450)
2. [gaia] a test_app to expose native functions 
3. [gaia-ui-tests] marionette tests to poke at gaia test app
I'd actually suggest starting simple first to get a sanity smoke test first that allows a login into persona in a trusted UI. Then tackle the depth of the tests you suggest.

If I wasn't so backlogged on due to late landing features I'd help out here (I actually started on this a bit back, but didn't finish).
(In reply to Jason Smith [:jsmith] from comment #1)
> I'd actually suggest starting simple first to get a sanity smoke test first
> that allows a login into persona in a trusted UI. Then tackle the depth of
> the tests you suggest.
> 
> If I wasn't so backlogged on due to late landing features I'd help out here
> (I actually started on this a bit back, but didn't finish).

That's actually exactly what I want to do, start simple, and have a strong foundation to build on.  I just mention the three components because there is code needed in each: In gecko the synthetic events workaround; In gaia, a test_app for exercising nav.id; In gaia-ui-tests, the actual tests.)

I'm currently trying to figure out how to translate what I can do in a python shell with marionette into a GaiaTestCase context.  Should have a gaia-ui-test PR soon.

In the mean time, my gaia-ui-tests wip is: 
https://github.com/jedp/gaia-ui-tests/commit/1bc90ec27eb8612ace7341ead1238ad7d83d02a6

For a gaia test app, I have submitted this PR:
https://github.com/mozilla-b2g/gaia/pull/7056

For gecko, I have a patch in Bug 822450

So the pieces are almost all in place

Updated

6 years ago
Blocks: 846517

Updated

6 years ago
No longer blocks: 794552

Updated

6 years ago
Duplicate of this bug: 808778
A lot has changed in the past six months.  Edwin and I are getting together in two days to revise these tests and add new ones according to zac's guidelines.
I think this bug got stale.  There have been gaia-ui-tests running for identity for months now.

I'm going to close this.  Please re-open if I'm in error.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.