"FM" open FM and incoming calls arrival, two voices rings together-617001919025

VERIFIED FIXED in Firefox 19

Status

Firefox OS
General
P2
normal
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: wu.bo3, Assigned: rlin)

Tracking

({regression})

unspecified
B2G C3 (12dec-1jan)
regression

Firefox Tracking Flags

(blocking-basecamp:+, firefox19 fixed, firefox20 fixed, b2g18 fixed)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.97 Safari/537.11

Steps to reproduce:

1.open FM
2.Incoming calls arrival
V0.0.0B01


Actual results:

Two voices rings together


Expected results:

Pause FM first, incoming calls ring playing
related to bug 796628; and also browser w/ flash and video.  bug 796628 is not fixed for all apps.  We need a system level fix or at least for every app that can play music.
Status: UNCONFIRMED → NEW
Ever confirmed: true
blocking-basecamp: --- → ?
blocking-basecamp: ? → +
Keywords: regression
Priority: -- → P2
Target Milestone: --- → B2G C3 (12dec-1jan)
Randy could you take a look?
Component: Gaia::Dialer → General
I was unable to reproduce on the 12/19 Unagi build. I got successful FM pause & restart.
Assignee: nobody → rlin
This *should* work without app-level changes anywhere. The platform should be pausing audio from all apps when the ringer starts.

wu.bo3@zte.com.cn: Are you possibly seeing bug 819852? Or is this different?
unable to reproduce on 12/21 unagi build.

Comment 6

5 years ago
I think we can close this bug since bug 815569 is landed 
if the bug related to the channel occupation, please move to bug 819852
thanks
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Comment 7

5 years ago
closing and tag verified
build id: 20121220092540
Status: RESOLVED → VERIFIED
status-b2g18: --- → fixed
status-firefox19: --- → fixed
status-firefox20: --- → fixed
Depends on: 815569
You need to log in before you can comment on or make changes to this bug.