All users were logged out of Bugzilla on October 13th, 2018

BUILD: no raptor in dll names

RESOLVED FIXED in M17

Status

P3
normal
RESOLVED FIXED
20 years ago
14 years ago

People

(Reporter: brendan, Assigned: cls)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2-], URL)

Attachments

(1 attachment)

(Reporter)

Description

20 years ago
No more raptor in DLL names, right?  raptorbase down, four or so to go.

/be

Updated

20 years ago
Status: NEW → ASSIGNED
Target Milestone: M8

Updated

20 years ago
Summary: BUILD: no raptor in dll names
Target Milestone: M8 → M9

Updated

20 years ago
Target Milestone: M9 → M10

Updated

19 years ago
Target Milestone: M10 → M14

Comment 1

19 years ago
We should add necko to the dll name list.

Updated

19 years ago
Target Milestone: M14 → M16

Comment 2

19 years ago
Dan veditz removed a lot of these on windows with his exercist of converting
dlls to 8.3

Suggestions ? necko->net ; raptor->layout

./components/libnecko.so
./components/libnecko_about.so
./components/libnecko_data.so
./components/libnecko_file.so
./components/libnecko_resource.so
./components/libnecko_ftp.so
./components/libnecko_http.so
./components/libnecko_keyword.so
./components/libraptorhtmlpars.so
./components/libraptorview.so
./components/libraptorhtml.so
./libraptorplugin.so
./libraptorgfx.so
./libraptorwebwidget.so

./res/samples/raptor.jpg
./components/necko_base.xpt
./components/necko_dns.xpt
./components/necko_socket.xpt
./components/necko_about.xpt
./components/necko_data.xpt
./components/necko_file.xpt
./components/necko_ftp.xpt
./components/necko_http.xpt
./components/necko_stream_converter.xpt

Comment 3

19 years ago
you really should be doing this _before_ you go to beta, not after. why M16?
The only reason we changed the necko names was because of the win 8.3
limitation. In the .dlls we used the abbreviation "nk", but we did not change
the name of any of the .xpt files.  The .xpt files should be the same
cross-platform so if you change them coordinate with mac and windows.

Comment 5

19 years ago
We didn't change the necko dll names because we intend to consolidate them into
2 dlls. (Bug 17031). Unfortunately Dan needed changes sooner.

Maybe somebody on the raptor team should own this task.

Updated

19 years ago
Assignee: dp → rickg
Status: ASSIGNED → NEW

Comment 6

19 years ago
Rick you want to own this ?

Updated

19 years ago
Target Milestone: M16 → M14

Updated

19 years ago
Target Milestone: M14 → M20

Comment 7

19 years ago
mass re-assign of all bugs where i was listed as the qa contact
QA Contact: cyeh → chofmann

Comment 8

19 years ago
This bug has been marked "future" because the original netscape engineer 
working on this is over-burdened. If you feel this is an error, that you or 
another known resource will be working on this bug,or if it blocks your work 
in some way -- please attach your concern to the bug for reconsideration. 
Target Milestone: M20 → Future
(Assignee)

Comment 9

19 years ago
IMO, if we are going to rename libs, we should've done it a year ago when this
bug was first opened.  Nominating for nsbeta2 status as we're talking about an
external end-user visible change.  I'll take the bug if necessary as I think all
that needs to be done are build changes and possible renaming of some files.

Keywords: nsbeta2

Comment 10

19 years ago
Putting on [nsbeta2-] radar. Not critical to beta2.
Whiteboard: [nsbeta2-]
(Reporter)

Comment 11

19 years ago
Rick, is it ok if cls takes this bug?  He's motivated and capable.

/be

Comment 12

19 years ago
Happy to have the help, thanks for the assist.
(Reporter)

Comment 13

19 years ago
Reassigning.

/be
Assignee: rickg → cls
(Reporter)

Comment 14

19 years ago
*** Bug 3700 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 15

19 years ago
Here are the current renaming suggestions:

MODULE=raptor		-> MODULE=layout
MODULE=raptor		-> MODULE=view (view/*/Makefile.in)
MODULE=raptor		-> MODULE=webshell (webshell/*/Makefile.in)
MODULE=raptor		-> MODULE=widget (widget/*/Makefile.in)
MODULE=raptor		-> MODULE=appshell (xpfe/appshell/*/Makefile.in)

libraptorgfx.so		-> libmozgfx.so
libraptorview.so	-> libmozview.so
libraptorplugin.so	-> libngplugin.so
libraptorhtmlpars.so	-> libhtmlpars.so
libraptorwebwidget.so	-> libwebshell.so
libraptorhtml.so	-> libnglayout.so

libraptorlayout_s.a	-> libnglbase_s.a
libraptorevents_s.a	-> libnglevents_s.a
libraptorhtmlbase_s.a	-> libnglhtmlbase_s.a
libnglhtmlcon_s.a	-> libnglhtmlcon_s.a
libraptorhtmldoc_s.a	-> libnglhtmldoc_s.a
libraptorhtmlforms_s.a	-> libnglhtmlforms_s.a
libraptorhtmlstyle_s.a	-> libnglhtmlstyle_s.a
libraptorhtmltable_s.a	-> libnglhtmltable_s.a
libraptorxmlcontent_s.a	-> libnglxmlcon_s.a
libraptorxmldoc_s.a	-> libnglxmldoc_s.a
libraptorxulcontent_s.a	-> libnglxulcon_s.a
libraptorxulbase_s.a	-> libnglxulbase_s.a
libraptorxbl_s.a	-> libnglxbl_s.a
libraptormathmlcontent_s.a -> libnglmathmlcon_s.a
libraptormathmlbase_s.a	-> libnglmathmlbase_s.a
libraptorsvgcontent_s.a	-> libnglsvgcon_s.a
libraptorsvgbase_s.a	-> libnglsvgbase_s.a
libraptorxsldoc_s.a	-> libnglxsldoc_s.a

libraptorbasewidget_s.a	-> libxpwidgets_s.a
Status: NEW → ASSIGNED

Comment 16

19 years ago
I'd prefer to see the prefix 'gk' rather than 'ngl'. We're using 'nk' for necko. 
"Next generation" will wear thin.
(Assignee)

Comment 17

19 years ago
Created attachment 10879 [details] [diff] [review]
patch to remove raptor from dlls for unix builds
(Assignee)

Updated

19 years ago
Target Milestone: Future → M17
(Assignee)

Comment 18

19 years ago
Patch has been tested on the commercial build and checked in.
Here are the last minute changes:
updated packages-unix
raptorgfx 	-> gkgfx
raptorplugin	-> gkplugin
raptorview	-> gkview

These are more inline with the names used by the win32 build.  Best I can tell,
someone (I think it was dveditz) already made the changes to win32.  raptor is
still used in a number of places for the intermediate static libs but not for
the dynamic ones.  There's also a bunch of references to -I$(PUBLIC)/raptor but
I was sure we stopped using that awhile ago. 

Marking fixed.

Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.