Closed Bug 822944 Opened 9 years ago Closed 9 years ago

Add production marketplace cert

Categories

(Core Graveyard :: DOM: Apps, defect, P1)

defect

Tracking

(blocking-b2g:tef+, blocking-basecamp:-, b2g18 fixed, b2g18-v1.0.0 affected, b2g18-v1.0.1 fixed)

RESOLVED FIXED
B2G C4 (2jan on)
blocking-b2g tef+
blocking-basecamp -
Tracking Status
b2g18 --- fixed
b2g18-v1.0.0 --- affected
b2g18-v1.0.1 --- fixed

People

(Reporter: briansmith, Assigned: briansmith)

References

Details

(Whiteboard: [target 28/2])

+++ This bug was initially created as a clone of Bug #772365 +++

We need to come up with some way that a store can sign an app package, and for Gecko to verify that signature against a list of stores that we trust.
(In reply to Brian Smith (:bsmith) from comment #0)
> We need to come up with some way that a store can sign an app package, and
> for Gecko to verify that signature against a list of stores that we trust.

Sorry. That was copied from the cloned bug. This bug is actually about making sure that the device trusts (only) the correct key before we ship.
blocking-basecamp: ? → +
Do we have the keys and do we know where they go? Anything blocking this work?
(In reply to Dietrich Ayala (:dietrich) from comment #2)
> Do we have the keys and do we know where they go? Anything blocking this
> work?

If we do, does it require marketplace changes?
(In reply to Dietrich Ayala (:dietrich) from comment #2)
> Do we have the keys and do we know where they go? Anything blocking this
> work?

My understanding is that we're not guaranteed to have the final cert before January 15th.

Wil, please make this bug depend on the marketplace bug for generating the final cert. (I am not sure what the bug number is.)
Thanks Brian. Marking blocking-b2g:tef+ to indicate that it's post-code-freeze work, but is required for final ship.
blocking-b2g: --- → tef+
blocking-basecamp: + → -
Priority: P1 → --
Target Milestone: B2G C4 (2jan on) → ---
opps...meant to keep the p1 on.
Priority: -- → P1
Depends on: 819053
Whiteboard: [awaiting bug 819053 (which is in turn blocked on bug 769729)][triaged:1/21]
Bug 819053 suggests this work will be done by 2/12.
Brian what is the status on this ?
Flags: needinfo?(bsmith)
(In reply to David Scravaglieri [:scravag] from comment #8)
> Brian what is the status on this ?

I can answer this one. I believe we're closing in on having the prod certs and resigning ready to go across marketplace and b2g, but we're full stop blocked due to MWC. We need an answer to the discussion thread I started on b2g-release-drivers on how to handle this situation.
Flags: needinfo?(bsmith)
Batch edit: Bugs marked status-b2g18: affected after 2/13 branching of v1.0.1 are now also status-b2g18-v1.0.1: affected
In this bug, we will add the marketplace production cert. In bug 841135, we will remove the test cert. There will be a short period of time when both certificates are trusted, to maximize the flexibility in doing the migration on the server side.
Summary: Replace marketplace cert with final version (with production key) → Add production marketplace cert
Whiteboard: [awaiting bug 819053 (which is in turn blocked on bug 769729)][triaged:1/21]
Is there a particular milestone we are waiting for to do this?
No longer depends on: 819053
(In reply to Lucas Adamski from comment #12)
> Is there a particular milestone we are waiting for to do this?

No. As soon as the final cert is ready, I will add it.
Whiteboard: [target 28/2]
There is no plans to get this done by 2/28. We have to wait until after MWC is finished.
Whiteboard: [target 28/2]
We cannot fix bug 841135 before the 28th but we can fix this bug before the 28th.
Whiteboard: [target 28/2]
https://hg.mozilla.org/mozilla-central/rev/b0e08db3bc2a
https://hg.mozilla.org/releases/mozilla-b2g18/rev/e055eda5f028
https://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/f8e2b5891d92

:kang gave me the cert and the test app as a patch and I modified his patch so that the prod cert and prod-cert-signed test app were added in addition to (instead of replacing) the test cert and test-cert-signed test app.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → B2G C4 (2jan on)
Duplicate of this bug: 845642
Blocks: 957451
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.