C4099 warning spam on MSVC

RESOLVED FIXED in mozilla20

Status

()

RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: emk, Assigned: emk)

Tracking

unspecified
mozilla20
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
It looks like it was caused by bug 817818.
Either revert the s/struct/class/; change or update also jspubtd.h.
(Assignee)

Updated

6 years ago
Duplicate of this bug: 823463
(Assignee)

Comment 2

6 years ago
Created attachment 694826 [details] [diff] [review]
Fix warning spam on MSVC
Assignee: general → VYV03354
Status: NEW → ASSIGNED
Attachment #694826 - Flags: review?(sphink)
Comment on attachment 694826 [details] [diff] [review]
Fix warning spam on MSVC

Review of attachment 694826 [details] [diff] [review]:
-----------------------------------------------------------------

::: js/src/jspubtd.h
@@ +190,5 @@
>  typedef struct JSPropertyDescriptor         JSPropertyDescriptor;
>  typedef struct JSPropertyName               JSPropertyName;
>  typedef struct JSPropertySpec               JSPropertySpec;
>  typedef struct JSRuntime                    JSRuntime;
> +class JSScript;

Can you preserve the semblance of C compatibility by moving JSFunction and JSScript into the #ifdef __cplusplus block? And add a C-only struct declaration, as with the others in that block.
Attachment #694826 - Flags: review?(sphink) → review+
Duplicate of this bug: 823589
https://hg.mozilla.org/mozilla-central/rev/847d24f0a8da
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla20
Duplicate of this bug: 811168

Updated

6 years ago
Duplicate of this bug: 824038
You need to log in before you can comment on or make changes to this bug.