The default bug view has changed. See this FAQ.

rules page doesn't update properly after new rule creation or existing rule updates

RESOLVED DUPLICATE of bug 938132

Status

Release Engineering
Balrog: Frontend
P3
normal
RESOLVED DUPLICATE of bug 938132
4 years ago
3 years ago

People

(Reporter: bhearsum, Assigned: bhearsum)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [balrog])

(Assignee)

Description

4 years ago
Noticed this while testing bug 739236. Two things, really:
1) When adding the very first rule to the database, it doesn't show up after submitting it until a refresh. I presume this is because the rules_table doesn't exist unless there's a rule in the system. (https://github.com/mozilla/balrog/blob/master/auslib/admin/templates/fragments/rules.html#L35)
2) When updating rules, data_version doesn't get updated until a page refresh. This might be related to the work done in bug 763005.

Updated

4 years ago
Priority: -- → P3
Product: mozilla.org → Release Engineering
(Assignee)

Comment 1

4 years ago
mass component change
Component: General Automation → Balrog: Frontend
(Assignee)

Updated

3 years ago
Blocks: 933414
(Assignee)

Comment 2

3 years ago
I think I'm fixing most of this as part of bug 938132...
Assignee: nobody → bhearsum
(Assignee)

Comment 3

3 years ago
I'm able to do both of the things noted in comment #0 with bug 938132 applied. Duping.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 938132
You need to log in before you can comment on or make changes to this bug.