Empty newsgroups list when trying to subscribe to a newsgroup

RESOLVED FIXED in Thunderbird 20.0

Status

MailNews Core
Networking: NNTP
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: mcsmurf, Assigned: Karsten Düsterloh)

Tracking

({regression})

Trunk
Thunderbird 20.0
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
To reproduce:
1. Fetch current trunk build
(1.1. Create a new test profile)
2. Create a new newsserver account (I created a news.mozilla.org account)
3. Try to subscribe a newsgroup

Results:
Empty newsgroup list, cannot subscribe to any newsgroup. According to Wireshark, the newsserver sends the correct response to the LIST command, so something is wrong in MailNews.

This is probably a regression.
Do you see entries if you enter a search term that matches something ?
(Reporter)

Comment 2

5 years ago
Yes, then I see something.
(Reporter)

Comment 3

5 years ago
Regressed between 2012-12-01 and 2012-12-02:
mozilla-central checkins: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=5c8ee6600533&tochange=0352a32fde64
comm-central checkins (by date): http://hg.mozilla.org/comm-central/pushloghtml?startdate=2012-11-30&enddate=2012-12-02+03%3A00
Keywords: regression
Status: UNCONFIRMED → NEW
Ever confirmed: true
Component: MailNews: General → Networking: NNTP
Product: SeaMonkey → MailNews Core
(Assignee)

Comment 4

5 years ago
Created attachment 695338 [details] [diff] [review]
fix fallout

More fallout from bug 814195.
Assignee: nobody → mnyromyr
Status: NEW → ASSIGNED
Attachment #695338 - Flags: review?(irving)
Attachment #695338 - Flags: review?(iann_bugzilla)
(Assignee)

Updated

5 years ago
Blocks: 814195
(Assignee)

Updated

5 years ago
OS: Windows 7 → All
Hardware: x86_64 → All

Updated

5 years ago
Attachment #695338 - Flags: review?(iann_bugzilla) → review+
Attachment #695338 - Flags: review?(irving) → review+
(Assignee)

Comment 5

5 years ago
https://hg.mozilla.org/comm-central/rev/d0a4dcf22c14
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
Duplicate of this bug: 826351

Updated

5 years ago
Target Milestone: --- → Thunderbird 20.0
You need to log in before you can comment on or make changes to this bug.