showing Cellbroadcast information

RESOLVED FIXED in B2G C3 (12dec-1jan)

Status

Firefox OS
Gaia
P1
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: brg, Assigned: yurenju)

Tracking

unspecified
B2G C3 (12dec-1jan)
x86
All

Firefox Tracking Flags

(blocking-basecamp:+)

Details

(Whiteboard: QARegressExclude)

Attachments

(5 attachments, 1 obsolete attachment)

(Reporter)

Description

5 years ago
Created attachment 694506 [details]
how it looks like under 3g

Now that cellbroadcast is landed(778093) we need the Gaia part to show the message broadcasted in 2G in network widget.

This is the minimum functionality in Gaia to show Cellbroadcast info. For sure we can be more ambitius for next releases and add the management of it in the sms app.
This is a mandatory requirement for ANATEL (regulatory entity in Brazil) and agreed months ago to be supported, so it should be blocker.
blocking-basecamp: --- → ?
(Reporter)

Updated

5 years ago
Blocks: 819528
Triage: BB+, C3, p1 - cert. blocker per comment 1
Yuren, can you take a look since it's about displaying cellbroadcast information in lockscreen? thanks
Assignee: nobody → yurenju
blocking-basecamp: ? → +
Priority: -- → P1
Target Milestone: --- → B2G C3 (12dec-1jan)
Seems very similar to what Anthony is working on currently -> re-assigning to him:)
Assignee: yurenju → anthony
Viven thought this was related to my work but it actually isn't. Re-assigning as I won't be able to test this for real either.
Assignee: anthony → yurenju
got spec from vicamo and investigating it.
spec provided by vicamo was Network info Requirements. But I need to know how to show cellbroadcast information on lockscreen.

Vicamo, do you know the right person who can give me cellbroadcast spec or behaviour?
Flags: needinfo?(vyang)
(In reply to Yuren Ju [:yurenju] from comment #6)
> spec provided by vicamo was Network info Requirements. But I need to know
> how to show cellbroadcast information on lockscreen.
> 
> Vicamo, do you know the right person who can give me cellbroadcast spec or
> behaviour?

We discussed this with VIVO during the working week held in Sao Paulo. I think that the information to be displayed in the lockscreen is the message received in the broadcast channel (no need to process it). Philip and Vicamo were also in that discussion, so correct me if I am wrong.
Created attachment 695974 [details]
pull request

https://github.com/mozilla-b2g/gaia/pull/7207
Attachment #695974 - Flags: review?(timdream+bugs)
Flags: needinfo?(vyang)
Comment on attachment 695974 [details]
pull request

Line 1 changes should be handled in mobile_operator.js

(You sure we need to change line 1 for this?)
Attachment #695974 - Flags: review?(timdream+bugs)
Created attachment 696227 [details]
pull request

confirmed with Vicamo, we should show cellbroadcast message on line 2. This pull request also fixed unit test for mobile_operator.js

https://github.com/mozilla-b2g/gaia/pull/7207
Attachment #695974 - Attachment is obsolete: true
Attachment #696227 - Flags: review?(timdream+bugs)
Comment on attachment 696227 [details]
pull request

r=me thanks
Attachment #696227 - Flags: review?(timdream+bugs) → review+
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Comment 13

5 years ago
Created attachment 697711 [details]
network indicator in US for at&t network

Updated

5 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 14

5 years ago
(In reply to Nick Dee from comment #13)
> Created attachment 697711 [details]
> network indicator in US for at&t network

Thanks for the attachment, this is network operator information but not cellbroadcast information. Please tell me if I am wrong but I think this isssue is not verified in this way.
Status: VERIFIED → RESOLVED
Last Resolved: 5 years ago5 years ago

Comment 15

5 years ago
Created attachment 697977 [details]
Unagi on at&t EDGE(2G) network

(In reply to Beatriz Rodríguez [:brg] from comment #14)
> (In reply to Nick Dee from comment #13)
> > Created attachment 697711 [details]
> > network indicator in US for at&t network
> 
> Thanks for the attachment, this is network operator information but not
> cellbroadcast information. Please tell me if I am wrong but I think this
> isssue is not verified in this way.

Here is another pic showing that device is connected to 2G network showing on a top banner next to signal bars as capital "E" (stands for EDGE) since device only supporting 1900MHz frequency on GSM it is all it going to get in US. Even it does have 2100MHz on UMTS I am not sure if at&t has 3G/4G in that frequency (even it suppose to have it according to Wikipedia) also we do not know what data plan is provisioned on our SIM cards.
(In reply to Nick Dee from comment #15)
> Created attachment 697977 [details]
> Unagi on at&t EDGE(2G) network
> 
> (In reply to Beatriz Rodríguez [:brg] from comment #14)
> > (In reply to Nick Dee from comment #13)
> > > Created attachment 697711 [details]
> > > network indicator in US for at&t network
> > 
> > Thanks for the attachment, this is network operator information but not
> > cellbroadcast information. Please tell me if I am wrong but I think this
> > isssue is not verified in this way.
> 
> Here is another pic showing that device is connected to 2G network showing
> on a top banner next to signal bars as capital "E" (stands for EDGE) since
> device only supporting 1900MHz frequency on GSM it is all it going to get in
> US. Even it does have 2100MHz on UMTS I am not sure if at&t has 3G/4G in
> that frequency (even it suppose to have it according to Wikipedia) also we
> do not know what data plan is provisioned on our SIM cards.

Hi Nick, there appears to be some confusion.  SMS-CB is only enabled for Vivo, see https://bugzilla.mozilla.org/show_bug.cgi?id=802121, so I'm not sure how testing on AT&T is going to help.

Comment 17

5 years ago
Ok I did research on  this issue and it is correct user have to have Vivo SIM Card inserted in the device and test it locally. according to forum : https://groups.google.com/forum/?fromgroups=#!topic/mozilla.dev.gaia/ieeNWeRy9Hc
(In reply to Nick Dee from comment #17)
> Ok I did research on  this issue and it is correct user have to have Vivo
> SIM Card inserted in the device and test it locally. according to forum :
> https://groups.google.com/forum/?fromgroups=#!topic/mozilla.dev.gaia/
> ieeNWeRy9Hc

I assume you're talking about the comment:

>> 5. During the work week at Brazil, can we have the testing environment for cell broadcast?
> Yes, CB messages are delivered by Vivo network, so we just need to test with a Vivo SIM Card inserted in the device.

So as long as your local network is Vivo then we're ok.

Comment 19

5 years ago
Created attachment 701989 [details]
screen shot for 3G only wi-fi off

Comment 20

5 years ago
This issue is fixed for  device Unagi; build #20130114073222v.1, Network broadcast information shows in lock screen, for Edge 2G "E", wi-fi, 3G unavailable at this time but does broadcast on lock screen " No network. Included screen shot of settings set to 3G only and wi-fi off.
Status: RESOLVED → VERIFIED
As stated in comment 14, this is not verified. From what I understand, someone in Brazil as to receive a message that will be displayed on the lockscreen to verify this. This has nothing to do with displaying the carrier name.
Status: VERIFIED → RESOLVED
Last Resolved: 5 years ago5 years ago

Updated

5 years ago
Whiteboard: QARegressExclude
I have verified this with commercial RIL.  Sorry for the delay.
(In reply to Michael Schwartz from comment #22)
> I have verified this with commercial RIL.  Sorry for the delay.

That's great news! Thanks Michael!
You need to log in before you can comment on or make changes to this bug.