Closed Bug 823903 Opened 8 years ago Closed 7 years ago

B2G RIL doesn't report the "searching" state

Categories

(Firefox OS Graveyard :: RIL, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-basecamp:-)

RESOLVED DUPLICATE of bug 866619
blocking-basecamp -

People

(Reporter: julienw, Unassigned)

References

Details

Attachments

(1 file)

In Bug 817660 I implemented the work to correctly display the icons depending on the state of the voice connection.

However it seems that the RIL doesn't report the 'searching' state so I can't display the 'searching' animated icon.

Nominating because I suspect that this might be a certification problem (tbc).
STR:
* patch your gecko with this patch
* flash the phone
* have a SIM in the phone
* watch your log as you boot the phone, enter your PIN, enable flight mode, disable flight mode, etc

Expected:
* we get the 'searching' state

Actual:
* we never get the 'searching' state
Flags: needinfo?(vyang)
Swu will discuss this with Vicamo to see if we have any comments.
AFAIK, the state string comes directly from AT+CREG <stat> index. If the underlying rild never reports such state, then we won't have it in Gecko. Android has only IN-SERVICE or OUT-SERVICE, no SEARCHING.
Flags: needinfo?(vyang)
So I guess we must find another way to display the "searching" icon. Will think of that but if we have an idea please tell ;)
"if *you* have", sorry.
Julien, why does this have to block?
Flags: needinfo?(felash)
Doug: because of this, we don't display the "searching network" icon (as defined in Bug 817660). It's not clear for me if this is mandatory for the certification, but the more I think about it, the more I think I could probably live without this.

So maybe this should not block.
Flags: needinfo?(felash)
blocking-basecamp: ? → -
Verified that Android does not display the searching state so this is probably not a certification requirement.
Depends on: 866619
Component: DOM: Device Interfaces → RIL
Product: Core → Boot2Gecko
Version: Trunk → unspecified
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 866619
You need to log in before you can comment on or make changes to this bug.