All users were logged out of Bugzilla on October 13th, 2018

Avoid resetting the theme on startup

RESOLVED FIXED in Firefox 19

Status

()

RESOLVED FIXED
6 years ago
2 years ago

People

(Reporter: sriram, Assigned: sriram)

Tracking

unspecified
Firefox 20
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox19 fixed, firefox20 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
When Gecko starts, if there is no theme, it sends a reset-theme message. This will cause all the registered views to set its own background again. This is unnecessary. We could use a state variable to monitor this -- just so to reset only if a theme is enabled.
(Assignee)

Updated

6 years ago
Blocks: 783092
(Assignee)

Comment 1

6 years ago
Created attachment 695038 [details] [diff] [review]
Patch

This ensures reset is called only if it is ever set.
Attachment #695038 - Flags: review?(mark.finkle)
Comment on attachment 695038 [details] [diff] [review]
Patch

This is OK, but could we use mBitmap as the "state"? If mBitmap is null, the theme is not enabled. If mBitmap is not null then the theme is enabled.

If we can use mBitmap, let's do it. If the boolean is better, I'm OK with it.
Attachment #695038 - Flags: review?(mark.finkle) → review+
https://hg.mozilla.org/mozilla-central/rev/30607c0b98c2
Assignee: nobody → sriram
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 20
(Assignee)

Comment 5

6 years ago
Comment on attachment 695038 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Optimization.
User impact if declined: None.
Testing completed (on m-c, etc.): Landed in m-c on 12/27
Risk to taking this patch (and alternatives if risky): Very low.
String or UUID changes made by this patch: None.

(This patch is required for Bug 816114).
Attachment #695038 - Flags: approval-mozilla-aurora?

Updated

6 years ago
Attachment #695038 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Updated

6 years ago
status-firefox19: --- → fixed
status-firefox20: --- → fixed
You need to log in before you can comment on or make changes to this bug.