Closed Bug 824516 Opened 7 years ago Closed 7 years ago

Regression: cannot select the content text

Categories

(Firefox for Android :: Text Selection, defect)

All
Android
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 20

People

(Reporter: tetsuharu, Assigned: tetsuharu)

References

Details

(Keywords: regression)

Attachments

(1 file)

Enviroment:
http://hg.mozilla.org/mozilla-central/rev/84320dffec6e

Status:
I cannot select the page text.

Info:
This error is shown in logcat:
JavaScript Error: "ReferenceError: rootElement is not defined" (file: "chrome://browser/content/browser.js" line: 1546

In Bug 708048 (http://hg.mozilla.org/mozilla-central/rev/ce34fa2b2189),  NativeWindow._sendToContent was fixed. But this patch has the mistake that did not change |rootElement| to |target|.
Attached patch patch v1Splinter Review
Attachment #695522 - Flags: review?(bugmail.mozilla)
Comment on attachment 695522 [details] [diff] [review]
patch v1

Review of attachment 695522 [details] [diff] [review]:
-----------------------------------------------------------------

Good catch, thanks.
Attachment #695522 - Flags: review?(bugmail.mozilla) → review+
Thank you for speedy review.
Does this patch fix bug 824516 as well?
Assignee: nobody → saneyuki.s.snyk
https://hg.mozilla.org/mozilla-central/rev/e4b389a23a95
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 20
Duplicate of this bug: 824948
You need to log in before you can comment on or make changes to this bug.