Last Comment Bug 824639 - Mozilla Firefox Issues With Ubuntu Studio (Low Latency) 12.0.4 Theme Colors
: Mozilla Firefox Issues With Ubuntu Studio (Low Latency) 12.0.4 Theme Colors
Status: RESOLVED DUPLICATE of bug 405207
:
Product: Firefox
Classification: Client Software
Component: Untriaged (show other bugs)
: 17 Branch
: x86_64 Linux
: -- major (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-25 12:49 PST by womanboss
Modified: 2013-01-08 04:08 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Google Search Field Grey Text (272.81 KB, image/png)
2012-12-25 12:49 PST, womanboss
no flags Details
Here is another view of the actual issue as you can see the text field is blue. (357.04 KB, image/png)
2012-12-25 12:53 PST, womanboss
no flags Details
Here is a Screenshot of my Ubuntu Theme on my desktop before the assumption is made that my applied Firefox Theme is causing the Blue Background you see. You may view this Screenshot as well. (704.29 KB, image/png)
2012-12-25 12:57 PST, womanboss
no flags Details
This is just one more Screenshot so that you can see the "Use System Colors" box is unticked. (302.80 KB, image/png)
2012-12-25 13:04 PST, womanboss
no flags Details
use_custom_colors preference Non-Existent (231.70 KB, image/png)
2012-12-25 15:17 PST, womanboss
no flags Details
When You Change The Ubuntu Desktop Theme The Text In Field Changes (250.16 KB, image/png)
2012-12-25 15:52 PST, womanboss
no flags Details

Description womanboss 2012-12-25 12:49:59 PST
Created attachment 695655 [details]
Google Search Field Grey Text

I have a serious issue with the dark themes in Ubuntu Studio 12.0.4 (Low Latency) & Mozilla Firefox 17.0.1. My input text for the most part on the Google Search Engine is a light Grey. The text box I am editing this text in has a Dark Blue background & white text.

Is there a way to force Mozilla Firefox to render standard colors? How can I prevent the theme colors from rendering in the web browser? There have been similar issues reported on previous versions of Mozilla Firefox. Please view this entry below:

http://askubuntu.com/questions/183564/high-contrast-theme-firefox-problem

I've researched this all to no avail.  Others have had a similar issues. Someone needs to address this either Mozilla or Ubuntu: https://bugzilla.mozilla.org/show_bug.cgi?id=417814
Comment 1 womanboss 2012-12-25 12:53:42 PST
Created attachment 695657 [details]
Here is another view of the actual issue as you can see the text field is blue.

Here is an additional screenshot for this issue. All of the form fields are blue.
Comment 2 womanboss 2012-12-25 12:57:41 PST
Created attachment 695658 [details]
Here is a Screenshot of my Ubuntu Theme on my desktop before the assumption is made that my applied Firefox Theme is causing the Blue Background you see. You may view this Screenshot as well.
Comment 3 womanboss 2012-12-25 13:04:24 PST
Created attachment 695660 [details]
This is just one more Screenshot so that you can see the "Use System Colors" box is unticked.
Comment 4 Josh Matthews [:jdm] (on vacation until Dec 5) 2012-12-25 13:20:59 PST
womanboss, if you visit about:config in Firefox (just type it in the URL bar), what is the value of the editor.use_custom_colors preference?
Comment 5 Josh Matthews [:jdm] (on vacation until Dec 5) 2012-12-25 13:23:56 PST
Actually, I'm unclear on precisely what behaviour you are expecting, versus what you are experiencing. Do you expect all textboxes to be light text on dark backgrounds, or something else?
Comment 6 womanboss 2012-12-25 15:17:06 PST
Created attachment 695679 [details]
use_custom_colors preference Non-Existent

The use_custom_colors preference is Non-Existent.  To further answer your question the major issue here is that you can't see text which is being rendered "Light Grey" on a white background.  The browser is defaulting to the system theme.  How do I know this you ask?  Because as soon as I change Ubuntu Studio 12.0.4 back to the default theme the text turns black in all the Google Search Form Field.  Thank you for your timely response.  Do I need to create that value you just mentioned (Non-Existent use_custom_colors preference)?  If so please provide instructions.
Comment 7 womanboss 2012-12-25 15:52:26 PST
Created attachment 695684 [details]
When You Change The Ubuntu Desktop Theme The Text In Field Changes

Also, my preference would be to have standard form fields unless denoted via a theme.  In this case the theme isn't causing the "Light Grey Background"--the Ubuntu desktop theme is dictating this behavior. See this screenshot as well.
Comment 8 womanboss 2012-12-25 15:54:21 PST
Apologies in advance I meant "Light Grey Text" as opposed to "Light Grey Background".
Comment 9 [:Aleksej] 2013-01-08 04:08:05 PST

*** This bug has been marked as a duplicate of bug 405207 ***

Note You need to log in before you can comment on or make changes to this bug.