B2G RIL: missing call.isActive in handleEnumerateCalls

RESOLVED FIXED in mozilla20

Status

()

defect
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: hsinyi, Assigned: hsinyi)

Tracking

unspecified
mozilla20
ARM
Gonk (Firefox OS)
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Follow-up of bug 816913. We missed 'isActive' property for enumerateCallState().
Posted patch patchSplinter Review
Attachment #695935 - Flags: review?(allstars.chh)
Attachment #695935 - Flags: review?(allstars.chh) → review+
https://hg.mozilla.org/mozilla-central/rev/bda50f10f69d
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla20
Comment on attachment 695935 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): this is follow-up of bug 816913. I am asking for approval because bug 816913 has been in aurora and beta already. thanks.
User impact if declined: 
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): low
String or UUID changes made by this patch: no
Attachment #695935 - Flags: approval-mozilla-beta?
Attachment #695935 - Flags: approval-mozilla-aurora?
We have already gone to build with our final FF18 beta and this will not be able to make it into it.Can you please help understand the user impact here and nominate it for b2g18 if this has a significant user impact ? 

we are considering only the code changes absolutely needed for b2g at this time considering how close we are to the release .
Attachment #695935 - Flags: approval-mozilla-beta? → approval-mozilla-beta-
Comment on attachment 695935 [details] [diff] [review]
patch

There needs to be an explicit user impact at this point given where we are in the cycle. Please re-nominate for uplift with more info or nominate for blocking-basecamp if you'd like to see this fixed for 1.0.
Attachment #695935 - Flags: approval-mozilla-b2g18-
Attachment #695935 - Flags: approval-mozilla-aurora?
Attachment #695935 - Flags: approval-mozilla-aurora-
You need to log in before you can comment on or make changes to this bug.