Fix five clang warnings in media/mtransport/

RESOLVED FIXED in mozilla21

Status

()

defect
RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: njn, Assigned: njn)

Tracking

(Blocks 1 bug)

Trunk
mozilla21
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [WebRTC], [blocking-webrtc-], [qa-])

Attachments

(1 attachment, 1 obsolete attachment)

clang 3.2. warns:

  media/mtransport/nricectx.h:180:8 [-Wunused-private-field] private field 'offerer_' is not used

  media/mtransport/nricemediastream.h:113:13 [-Wunused-private-field] private field 'components_' is not used

  media/mtransport/test/runnable_utils_unittest.cpp:48:52 [-Wextra-semi] extra ';' inside a class

  media/mtransport/test/sctp_unittest.cpp:265:22 [-Wunused-private-field] private field 'peer_' is not used
  media/mtransport/test/sctp_unittest.cpp:269:8 [-Wunused-private-field] private field 'gathering_complete_' is not used
  media/mtransport/test/sctp_unittest.cpp:271:10 [-Wunused-private-field] private field 'to_send_' is not used
This patch fixes the warnings.
Attachment #696186 - Flags: review?(rjesup)
Comment on attachment 696186 [details] [diff] [review]
Fix five clang warnings in media/mtransport/.

Review of attachment 696186 [details] [diff] [review]:
-----------------------------------------------------------------

Ponging review to ekr, who wrote this code.  It's possible some of these unused params are intended for future updates and we want to keep the API unchanged.  Also, this is an imported module, so there may be issues there.
Attachment #696186 - Flags: review?(rjesup) → review?(ekr)
Blocks: buildwarning
Comment on attachment 696186 [details] [diff] [review]
Fix five clang warnings in media/mtransport/.

Review of attachment 696186 [details] [diff] [review]:
-----------------------------------------------------------------

The unused params in nricectx* are intended for future use. The other changes are fine/
> The unused params in nricectx* are intended for future use.

I'll reinstate them, add a |(void)foo;| usage to quell the warning, and add a short comment about the future usage.
Whiteboard: [WebRTC], [blocking-webrtc-]
Updated version.
Attachment #696906 - Flags: review?(ekr)
Attachment #696186 - Attachment is obsolete: true
Attachment #696186 - Flags: review?(ekr)
ekr: review ping.  This is a trivial patch.
Attachment #696906 - Flags: review?(ekr) → review+
Some of the warnings were fixed in the meantime.  The landed patch fixes the two remaining ones.

https://hg.mozilla.org/integration/mozilla-inbound/rev/32c248cf7474
Duplicate of this bug: 836196
Blocks: 836570
Version: unspecified → Trunk
https://hg.mozilla.org/mozilla-central/rev/32c248cf7474
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla21
Whiteboard: [WebRTC], [blocking-webrtc-] → [WebRTC], [blocking-webrtc-], [qa-]
Duplicate of this bug: 801307
You need to log in before you can comment on or make changes to this bug.