No working SUT agent on the b2g panda images - Add Negatus back to the nightly branch and update negatus snapshot used for panda builds

RESOLVED FIXED

Status

RESOLVED FIXED
6 years ago
7 months ago

People

(Reporter: jgriffin, Assigned: armenzg)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(firefox19 fixed, b2g18 fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
We need to update the version of the negatus repo used to generate panda builds so it can pick up the changes from bug 823122.  Specifically, we need to get https://github.com/mozilla/Negatus/commit/7ed4efcee655f605455f9375a4e6c68cd078c459.
(Assignee)

Updated

6 years ago
Blocks: 802317
(Assignee)

Updated

6 years ago
Assignee: nobody → armenzg
(Assignee)

Comment 1

6 years ago
Created attachment 697061 [details] [diff] [review]
update b2g panda snapshot

I'm not sure if this is the right way to update Negatus on the b2g image.

Updating the snapshot gave me only this two changes which seem unrelated:
https://github.com/mozilla-b2g/platform_build/compare/273ba23d5c6c9f6a34995a3cc429804d1449ca9f...69380784721ae11af93ef4e1b5ce8a54e8570574
https://github.com/mozilla-b2g/gonk-misc/compare/7c43e273991a8a66afc88c888befb2830b7640e1...ffc42185726384eaa80ea685bd9c95b7dab467c3

I have no idea on how we get negatus unto the b2g images
https://github.com/mozilla/Negatus

I cannot even match the string "negatus" on a panda's build log.
Under a local b2g build you need to clone the Negatus repo under the $B2G_HOME/system (see https://github.com/mozilla/Negatus). Then some build system magic will detect and pick it up. I'm not exactly sure what happens after this point, but hopefully this can point you in the right direction.

CC'ing mihnea as he might know a bit more than me about how it works.
(Reporter)

Comment 3

6 years ago
Negatus gets synced as part of the panda build courtesy of this line in the manifest:  https://github.com/mozilla-b2g/b2g-manifest/blob/master/pandaboard.xml#L105.

But, I'm not sure how that translates into how rel-eng builds are produced; catlee, do you know?
(Assignee)

Comment 4

6 years ago
It seems that it got removed automatically on December 20th when I generated the b2g snapshot for bug 822444.
https://hg.mozilla.org/mozilla-central/rev/d81af339bb7a
    2.94 -  <project name="Negatus" path="external/negatus" remote="mozilla" revision="5d5288e7bec67d0a6a29320308cccb1321062b58"/>
    2.95 -  <project name="orangutan" path="external/orangutan" remote="b2g" revision="601280aed7d7f29f1a78496f6fa41bd79c16305c"/>
(Assignee)

Comment 5

6 years ago
That removal would also explain why the devices that have been recently imaged did not have sut running on them.
(Assignee)

Comment 6

6 years ago
While we figure out why our snapshot generation removed negatus I have gone and triggered a try build adding this:
+  <project name="Negatus" path="external/negatus" remote="mozilla" revision="7ed4efcee655f605455f9375a4e6c68cd078c459"/>

https://tbpl.mozilla.org/?tree=Try&rev=7d064786d5d2

I assume that pandas that get re-imaged with that build should come back up with Negatus running on them.
(In reply to Armen Zambrano G. [:armenzg] from comment #6)
> While we figure out why our snapshot generation removed negatus I have gone
> and triggered a try build adding this:
> +  <project name="Negatus" path="external/negatus" remote="mozilla"
> revision="7ed4efcee655f605455f9375a4e6c68cd078c459"/>
> 
> https://tbpl.mozilla.org/?tree=Try&rev=7d064786d5d2

The sources.xml which is in in-tree is informational only, it doesn't get used to pull source during builds (not yet, anyway). The gonk snapshot in that push (e3ac0a10d9b3ac7473....) doesn't contain the negatus source, so it's not the fix you need.

The issue is related to the b2g-manifests repo. Since 
 https://github.com/mozilla-b2g/B2G/commit/41d2014b1f88a9190963551f5114e2cb1e45edb8
aka bug 822970, B2G/config.sh defaults to the nightly branch instead of master. The changes to pandaboard.xml which added negatus and orangutan aren't on the nightly branch of b2g-manifests. Is that something you look after jgriffin ?
(Assignee)

Comment 8

6 years ago
Thanks nthomas!

Right now we don't have Negatus on the b2g image anymore and all of the gaia ui tests jobs are failing.

I don't see negatus specified on the nightly branch:
https://github.com/mozilla-b2g/b2g-manifest/blob/nightly/pandaboard.xml#L100
but I do on the master branch:
https://github.com/mozilla-b2g/b2g-manifest/blob/master/pandaboard.xml#L105
Summary: Update negatus snapshot used for panda builds → No working SUT agent on the b2g panda images - Add Negatus back to the nightly branch and update negatus snapshot used for panda builds
(Assignee)

Comment 9

6 years ago
Pull request:
https://github.com/mozilla-b2g/b2g-manifest/pull/38

How can I ask for a reviewer on github?
(Assignee)

Comment 10

6 years ago
Thomas reviewed it and merged it.
Here is the commit:
https://github.com/mozilla-b2g/b2g-manifest/commit/20e8dc1f0b5478c9b67b6c6f8ca5a52baff42689

Do I need to create a new snapshot?
(Assignee)

Updated

6 years ago
Whiteboard: NOTE: Uplifting needed
(Reporter)

Updated

6 years ago
Attachment #697501 - Flags: review?(jgriffin) → review+
(Assignee)

Comment 14

6 years ago
$>clok    
1357567948
$>setutime 1357242567371  
1357242567371
$>clok
1357242570492
Status: NEW → ASSIGNED
(Assignee)

Comment 15

6 years ago
Comment on attachment 697501 [details] [diff] [review]
update b2g snapshot

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
* Adding test infra. n/a

User impact if declined: 
* N/A. No b2g panda testing on those branches.

Testing completed: 
* Landed on m-c and tested on Cedar. There is only b2g panda testing on Cedar for now.

Risk to taking this patch (and alternatives if risky): 
* None

String or UUID changes made by this patch:
* None
Attachment #697501 - Flags: approval-mozilla-b2g18?
Attachment #697501 - Flags: approval-mozilla-aurora?
(Assignee)

Comment 16

6 years ago
Comment on attachment 697501 [details] [diff] [review]
update b2g snapshot

I just found out about a=NPOTB
Attachment #697501 - Flags: approval-mozilla-b2g18?
Attachment #697501 - Flags: approval-mozilla-aurora?
(Assignee)

Comment 17

6 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/3c1dad789ad8
https://hg.mozilla.org/releases/mozilla-b2g18/rev/7fb7921a1066
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Updated

6 years ago
status-b2g18: --- → fixed
status-firefox19: --- → fixed
(Assignee)

Updated

6 years ago
Whiteboard: NOTE: Uplifting needed
Product: mozilla.org → Release Engineering
Component: General Automation → General
Product: Release Engineering → Release Engineering
You need to log in before you can comment on or make changes to this bug.