Last Comment Bug 825449 - Filter editor: Accesskey for 'Perform these actions' should set/move focus to first action item (at the moment invisible/not shown)
: Filter editor: Accesskey for 'Perform these actions' should set/move focus to...
Status: RESOLVED FIXED
:
Product: MailNews Core
Classification: Components
Component: Filters (show other bugs)
: Trunk
: All All
: -- enhancement (vote)
: Thunderbird 22.0
Assigned To: :aceman
:
:
Mentors:
: 543223 (view as bug list)
Depends on: 1024908
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-29 11:57 PST by Sebastian Hengst [:aryx][:archaeopteryx] (needinfo on intermittent or backout)
Modified: 2014-06-13 01:33 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
patch (1.29 KB, patch)
2013-01-05 14:34 PST, :aceman
bwinton: ui‑review+
aryx.bugmail: feedback+
Details | Diff | Splinter Review
patch v2 (4.36 KB, patch)
2013-02-18 13:39 PST, :aceman
rkent: review+
bwinton: ui‑review+
Details | Diff | Splinter Review

Description Sebastian Hengst [:aryx][:archaeopteryx] (needinfo on intermittent or backout) 2012-12-29 11:57:40 PST
Thunderbird Earlybird 19.0a2 20121229

At the moment, the filter editor for creating/editing a filter has the box 'Perform these actions' with access key 'P'. Pressing this access key will move it to the label, there is no focus shown and nothing can be done there, so it should be set to the first action item in that box.
Comment 1 :aceman 2013-01-05 12:39:48 PST
You mean focus the first action menulist?
Comment 2 Sebastian Hengst [:aryx][:archaeopteryx] (needinfo on intermittent or backout) 2013-01-05 13:55:06 PST
Yes (at least something with a focus ring indicator).
Comment 3 :aceman 2013-01-05 14:34:32 PST
Created attachment 698342 [details] [diff] [review]
patch

Ok, here you go.
Comment 4 Sebastian Hengst [:aryx][:archaeopteryx] (needinfo on intermittent or backout) 2013-01-05 15:07:40 PST
Comment on attachment 698342 [details] [diff] [review]
patch

Thank you, your fix works like I imagined.
Comment 5 Blake Winton (:bwinton) (:☕️) 2013-02-16 11:30:57 PST
Comment on attachment 698342 [details] [diff] [review]
patch

Okay so ui-r=me if (and this is a big if!), when you've selected item 3, and focus another element, and then re-focus the list, item 3 is still the focused one.  (Does that make sense?  I can't seem to compile, so I'm sort of going by inspection here…)

Thanks,
Blake.
Comment 6 :aceman 2013-02-18 13:39:57 PST
Created attachment 715232 [details] [diff] [review]
patch v2

Ok, if you think so.
Comment 7 Kent James (:rkent) 2013-02-21 12:38:00 PST
Comment on attachment 715232 [details] [diff] [review]
patch v2

Looks fine to me. Thanks for the patch!
Comment 8 Blake Winton (:bwinton) (:☕️) 2013-02-23 18:17:14 PST
Comment on attachment 715232 [details] [diff] [review]
patch v2

Seems good.  ui-r=me.
Comment 9 Ryan VanderMeulen [:RyanVM] 2013-02-25 06:52:01 PST
https://hg.mozilla.org/comm-central/rev/525b199453d9
Comment 10 :aceman 2013-05-06 14:18:38 PDT
*** Bug 543223 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.