Closed Bug 825987 Opened 7 years ago Closed 7 years ago

Regression: Save As PDF renders JPEGs as black rectangles

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 21
Tracking Status
firefox18 - wontfix
firefox19 + fixed
firefox20 + fixed
firefox21 --- verified
fennec 19+ ---

People

(Reporter: nsaedgar, Assigned: ajones)

References

(Blocks 1 open bug)

Details

(Keywords: regression, reproducible)

Attachments

(2 files)

Attached file miklowei.pdf
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:17.0) Gecko/20100101 Firefox/17.0
Build ID: 20121128204232

Steps to reproduce:

saved a pdf


Actual results:

Save As PDF renders JPEGs as black rectangles


Expected results:

save as jpg
Which version of Firefox on Android are you running? The latest version on Google Play? This was fixed over a year ago for XUL Fennec in bug 704185 (this would be a dupe of bug 758893).
(In reply to Aaron Train [:aaronmt] from comment #1)
> Which version of Firefox on Android are you running? The latest version on
> Google Play? This was fixed over a year ago for XUL Fennec in bug 704185
> (this would be a dupe of bug 758893).

latest from GP ~ v18
OS: Windows XP → Android
Which phone, version of Android and website do you get this with?
<http://www.bridgesmathart.org/art-exhibits/bridges06/miklowei.html>

Samsung Galaxy Tab 7.0

Android 3.2
This works for me fine on my Galaxy Note II/Galaxy Nexus (Android 4.2)

Honeycomb issue? Anyone able to reproduce?
I add that I get the black rectangle only with some sites, e.g. the bridgesmarthart site indicated.
Hey :xti, are you able to reproduce?
Flags: needinfo?(nicolae.cristian)
(In reply to Aaron Train [:aaronmt] from comment #7)
> Hey :xti, are you able to reproduce?

No, I cannot reproduce it on the latest Nightly either, but it occurs on Firefox 18 RC 1.

--
Firefox 20.0a1 (2013-01-07)
Device: Galaxy Tab2 10.1
OS: Android 3.1
Flags: needinfo?(nicolae.cristian)
Hardware: x86 → ARM
It would be nice to know what fixed this. Does that mean it's a Honeycomb only issue, xti?
(In reply to Aaron Train [:aaronmt] from comment #9)
> It would be nice to know what fixed this. Does that mean it's a Honeycomb
> only issue, xti?

It looks like to be specific to Honeycomb only. I cannot reproduce this issue on ICS/JB. Since the tinderbox inbound builds for this issue/fix are not longer on the server, should I still try to find the window for the good patch?
(In reply to Cristian Nicolae (:xti) from comment #10)
> (In reply to Aaron Train [:aaronmt] from comment #9)
> > It would be nice to know what fixed this. Does that mean it's a Honeycomb
> > only issue, xti?
> 
> It looks like to be specific to Honeycomb only. I cannot reproduce this
> issue on ICS/JB. Since the tinderbox inbound builds for this issue/fix are
> not longer on the server, should I still try to find the window for the good
> patch?

trunk-nightly builds would help at least I think
I see this when saving a PDF of the front-page of http://www.neowin.net -- reproducible on trunk (mozilla-21)
Status: UNCONFIRMED → NEW
tracking-fennec: --- → ?
Ever confirmed: true
Summary: Save As PDF renders JPEGs as black rectangles → Regression: Save As PDF renders JPEGs as black rectangles
Version: Firefox 18 → Trunk
mozilla-18 affected; bug 691061?

CC Anthony? Jeff?
That seems likely.
Can we get a backout of bug 691061 ready for a possible 18.0.1?
v. 19 cures the problem with <http://www.bridgesmathart.org/art-exhibits/bridges06/miklowei.html>.
However, <http://www.bridgesmathart.org/art-exhibits/bridges2009/bulatov.html> is still has black rectangles.
(In reply to Mark Finkle (:mfinkle) from comment #16)
> Can we get a backout of bug 691061 ready for a possible 18.0.1?

Mark, this seems to be impacting only honeycomb users, & considering we do not have strong drivers for mobile 18.0.1, this will have to wait till FX 19.
Please let us know if you think this a very serious user facing issue & could be a driver itself else we will wontfix it for Fx18. Thanks.
(In reply to bhavana bajaj [:bajaj] from comment #19)
> (In reply to Mark Finkle (:mfinkle) from comment #16)
> > Can we get a backout of bug 691061 ready for a possible 18.0.1?
> 
> Mark, this seems to be impacting only honeycomb users, & considering we do
> not have strong drivers for mobile 18.0.1, this will have to wait till FX 19.
> Please let us know if you think this a very serious user facing issue &
> could be a driver itself else we will wontfix it for Fx18. Thanks.

Sorry, I forgot to mention that I can reproduce on all platforms.
(In reply to Aaron Train [:aaronmt] from comment #20)
> (In reply to bhavana bajaj [:bajaj] from comment #19)
> > (In reply to Mark Finkle (:mfinkle) from comment #16)
> > > Can we get a backout of bug 691061 ready for a possible 18.0.1?
> > 
> > Mark, this seems to be impacting only honeycomb users, & considering we do
> > not have strong drivers for mobile 18.0.1, this will have to wait till FX 19.
> > Please let us know if you think this a very serious user facing issue &
> > could be a driver itself else we will wontfix it for Fx18. Thanks.
> 
> Sorry, I forgot to mention that I can reproduce on all platforms.

Sorry,still this did not feel being a driver for 18.0.1 & so wontfixing it at this time. Although please nominate for uplifts on branches as needed . Thanks
Assignee: nobody → ajones
tracking-fennec: ? → 19+
I've pinged Anthony and roc in email about a backout.
Try run for d397457363ea is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=d397457363ea
Results (out of 174 total builds):
    exception: 1
    success: 165
    warnings: 7
    failure: 1
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/ajones@mozilla.com-d397457363ea
https://hg.mozilla.org/mozilla-central/rev/f6a638c16bd4
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 21
(In reply to Anthony Jones (:kentuckyfriedtakahe) from comment #23)
> Created attachment 705198 [details] [diff] [review]
> Back out patch for bug 691061

Please nominate for uplift to FF19 with a risk evaluation as soon as possible. Thanks!
(beta 5, the last opportunity to take this fix, is going to build tomorrow)
Regression resolved on trunk, yes, please nominate.
Status: RESOLVED → VERIFIED
Comment on attachment 705198 [details] [diff] [review]
Back out patch for bug 691061

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 691061
User impact if declined: Broken JPEG when saving as PDF
Testing completed (on m-c, etc.): Already on m-c. This is a backout.
Risk to taking this patch (and alternatives if risky): Increased PDF size.
String or UUID changes made by this patch: None
Attachment #705198 - Flags: approval-mozilla-beta?
Comment on attachment 705198 [details] [diff] [review]
Back out patch for bug 691061

Approving for uplift. Thanks Anthony!
Attachment #705198 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.