Last Comment Bug 826037 - Re-introduce an obsolete private browsing service in order to not break all Jetpack add-ons
: Re-introduce an obsolete private browsing service in order to not break all J...
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Private Browsing (show other bugs)
: unspecified
: All All
: -- normal (vote)
: Firefox 20
Assigned To: :Ehsan Akhgari
:
Mentors:
Depends on:
Blocks: PBnGen 818800 825471 825508
  Show dependency treegraph
 
Reported: 2013-01-02 13:17 PST by :Ehsan Akhgari
Modified: 2013-01-18 15:54 PST (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (v1) (4.96 KB, patch)
2013-01-02 13:56 PST, :Ehsan Akhgari
josh: review+
Details | Diff | Splinter Review

Description :Ehsan Akhgari 2013-01-02 13:17:41 PST
See bug 825471 for the sad sad details. :(
Comment 1 :Ehsan Akhgari 2013-01-02 13:56:40 PST
Created attachment 697195 [details] [diff] [review]
Patch (v1)
Comment 2 :Gavin Sharp [email: gavin@gavinsharp.com] 2013-01-02 13:59:00 PST
use the C-comment license header rather than the preprocessor one, and then you can get rid of the EXTRA_PP_COMPONENTS (preprocessing unnecessarily makes build slow).
Comment 3 Josh Matthews [:jdm] 2013-01-02 14:31:13 PST
Comment on attachment 697195 [details] [diff] [review]
Patch (v1)

Review of attachment 697195 [details] [diff] [review]:
-----------------------------------------------------------------

What Gerv said.
Comment 4 :Ehsan Akhgari 2013-01-02 14:33:14 PST
(In reply to comment #3)
> What Gerv said.

Gerv?  ;-)
Comment 6 :Ehsan Akhgari 2013-01-02 15:30:47 PST
I forgot half of the patch :(

https://hg.mozilla.org/integration/mozilla-inbound/rev/fcab6193a0fa
Comment 7 Wes Kocher (:KWierso) 2013-01-02 16:23:10 PST
Looks like the tests are running again, and it's mostly just the private-browsing tests that are failing now, which is probably expected, since they're still trying to test the old stuff that isn't there anymore.
Comment 9 Ben Bucksch (:BenB) 2013-01-18 15:53:22 PST
> See bug 825471 for the sad sad details. :(

I find 818800 comment 16 sad, too.
Comment 10 Ben Bucksch (:BenB) 2013-01-18 15:54:13 PST
Sorry, linked: Bug 818800 comment 16

Note You need to log in before you can comment on or make changes to this bug.