CardView gets on top of the lockscreen

RESOLVED FIXED

Status

Firefox OS
Gaia::System
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: etienne, Assigned: ttaubert)

Tracking

unspecified

Firefox Tracking Flags

(blocking-basecamp:-, b2g18+ fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
STR:
- Lock the phone
- Longpress home button

Expected:
- Nothing

Actual:
- The card view appears on top of the lockscreen

Note:
Taping the app wont display it (since the lockscreen is on top) but we're still displaying private informations by showing the apps screenshots in the card view.
(Reporter)

Comment 1

5 years ago
Nominating because of the privacy issue.
blocking-basecamp: --- → ?
Assignee: nobody → alive
Triage: BB-, tracking-b2g18+, would take a patch if there is a quick and easy fix
blocking-basecamp: ? → -
tracking-b2g18: --- → +
Duplicate of this bug: 826561
(Assignee)

Comment 4

5 years ago
Created attachment 697873 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/7291

Pointer to Github pull-request
(Assignee)

Comment 5

5 years ago
Comment on attachment 697873 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/7291

Ugly bug. Really quick and easy fix.
Attachment #697873 - Flags: review?(mbudzynski)
(Reporter)

Comment 6

5 years ago
(In reply to Tim Taubert [:ttaubert] from comment #5)
> Comment on attachment 697873 [details]
> Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/7291
> 
> Ugly bug. Really quick and easy fix.

\o/
Attachment #697873 - Flags: review?(mbudzynski) → review+
r=me https://github.com/mozilla-b2g/gaia/commit/9c8474df0fe7715a35ea2991208e5031c6436e2e

Thanks!
(Assignee)

Comment 8

5 years ago
Thanks for the quick merge :)
Assignee: alive → ttaubert
Status: NEW → RESOLVED
Last Resolved: 5 years ago
OS: Linux → All
Hardware: x86_64 → All
Resolution: --- → FIXED
status-b2g18: --- → fixed
You need to log in before you can comment on or make changes to this bug.