Canceling UI for per-window private browsing autostart mode, doesn't revert browser.privatebrowsing.autostart preference

RESOLVED FIXED in Firefox 20

Status

()

RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: morac, Assigned: Ehsan)

Tracking

Trunk
Firefox 20
x86
Windows XP
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Bug 801823 added a UI to force the browser to restart if the user tries to enable private browsing autostart mode.  The problem is that if the user cancels the prompt, the browser.privatebrowsing.autostart isn't reverted to the original value so a restart isn't "required" to change the setting.

Steps to reproduce:
1. Open options and change the "Firefox will" setting on the Privacy tab.
2. Click Okay.
3. At prompt click cancel.

At this point the options window will close, but the browser.privatebrowsing.autostart preference will be changed.  This can be verified by re-opening the Options window or checking about:config


I looked at the code and it appears that the options in the preference window are being reverted (and I can see this quickly before the option window closes), but since the "Okay" button was clicked and the options window is closing, that doesn't actually revert the preference change.  

Either the close of the options window needs to be stopped or (and this is better since the user could then cancel the options) the prefs.valueFromPreferences should be reverted.


Also I'll mention the options window UI change does nothing to prevent the actual changing of the browser.privatebrowsing.autostart preference from something like the about:config page (or any where other than the options window).
(Assignee)

Comment 1

6 years ago
(In reply to Michael Kraft [:morac] from comment #0)
> Also I'll mention the options window UI change does nothing to prevent the
> actual changing of the browser.privatebrowsing.autostart preference from
> something like the about:config page (or any where other than the options
> window).

Yes, that is intentional.  That is not a supported way of turning this feature on.
(Assignee)

Updated

6 years ago
Blocks: 463027
(Assignee)

Updated

6 years ago
Assignee: nobody → ehsan
(Assignee)

Comment 2

6 years ago
Created attachment 697552 [details] [diff] [review]
Patch (v1)

We just need to make sure that the autostart pref is always instantApply, even on Windows.  I also took out the obsolete keep_current_session pref while I was there.
Attachment #697552 - Flags: review?(josh)

Updated

6 years ago
Attachment #697552 - Flags: review?(josh) → review+

Comment 4

6 years ago
https://hg.mozilla.org/mozilla-central/rev/2c7919e052be
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 20
(Assignee)

Updated

6 years ago
Depends on: 842290
You need to log in before you can comment on or make changes to this bug.