Closed Bug 826410 Opened 12 years ago Closed 12 years ago

nsHTMLMediaElement is missing nsIAudioChannelAgentCallback in its QI impl

Categories

(Core :: DOM: Core & HTML, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla20
blocking-b2g tef+
Tracking Status
firefox20 --- fixed
b2g18 --- fixed
b2g18-v1.0.0 --- wontfix
b2g18-v1.0.1 --- fixed

People

(Reporter: mrbkap, Assigned: mrbkap)

References

Details

(Whiteboard: [TD-8379])

Attachments

(1 file)

Attached patch FixSplinter Review
This leads to assertions in b2g debug builds.
Attachment #697593 - Flags: review?(jst)
Attachment #697593 - Flags: approval-mozilla-b2g18?
Assignee: nobody → mrbkap
Comment on attachment 697593 [details] [diff] [review]
Fix

We should also add a chrome caller check to nsHTMLMediaElement::CanPlayChanged() to make sure it can never be called by untrusted script. Please add that here as well so web pages can't interfere here and re-request approval on that patch.
Attachment #697593 - Flags: review?(jst)
Attachment #697593 - Flags: review+
Attachment #697593 - Flags: approval-mozilla-b2g18?
Attachment #697593 - Flags: approval-mozilla-b2g18-
https://hg.mozilla.org/mozilla-central/rev/d1905a0ba1ed
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla20
Bug caused by (feature/regressing bug #): Regression Bug 815069
User impact if declined: AudioChannelAgent will be broken on nsHTMLMediaElement (b2g18 branch). So Audio Competing Policy will be malfunctional.
Testing completed: Do the testing on b2g18.
Risk to taking this patch (and alternatives if risky): No.
String or UUID changes made by this patch: No.

This problem is exposed by bug Bug 857653, and since it is tef+. This should be a tef+ too.
We need to set some flag in order for this to be considered for b2g uplift.  I'll set tef?; this blocks a blocker.
blocking-b2g: --- → tef?
as per comment 6 blocks a blocker
blocking-b2g: tef? → tef+
Whiteboard: [TD-8379]
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: