Closed Bug 826765 Opened 10 years ago Closed 10 years ago

- Camera - preview occasionally doesn't appear after mode switch during camera rotation

Categories

(Firefox OS Graveyard :: Gaia::Camera, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 830995

People

(Reporter: sotaro, Unassigned)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20121231071231

Steps to reproduce:

1. start Camera application
2. change video/camera mode repeatedly by pushing the mode change button during rotating the camera angle between horizontal and vertical




Actual results:

preview does not appear on the screen. It is totally black.
After killing camera application, it works as normal.

It is necessary to do "2" part very quickly and repeatedly.
Sometimes, it takes long time to generate this.


Expected results:

preview always appears as normal.
Unagi phone, build 2013-01-03
During "2" part, Browser app is occasionally started.
I tried to generate this without rotating the device. But it did not succeed.
Duplicate of this bug: 829177
Status: UNCONFIRMED → NEW
Ever confirmed: true
Hardware: All → ARM
OS: All → Gonk (Firefox OS)
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 830995
You need to log in before you can comment on or make changes to this bug.