Closed Bug 826819 Opened 7 years ago Closed 7 years ago

Show different "Add tab" icons for normal and private tabs in Tabs Panel

Categories

(Firefox for Android :: Theme and Visual Design, defect)

ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 21
Tracking Status
firefox20 --- verified
firefox21 --- verified

People

(Reporter: sriram, Assigned: sriram)

References

Details

Attachments

(4 files, 1 obsolete file)

Currently just the same "+" is used for adding a new tab/private tab in Tabs Panel. We need a visual demarcation.
Blocks: 824469
Yay! Holo theme Yay!
This changes the border from a gradient+shadow to a plain solid color.
Attachment #700570 - Flags: review?(mark.finkle)
Attached patch Part 2: Replace private icons (obsolete) — Splinter Review
The cute little private tab icons -- more like mask of zorro than a acting company's mask :D
Attachment #700572 - Flags: review?(mark.finkle)
Previous patch missed the tablet part. That's fixed here.
Attachment #700572 - Attachment is obsolete: true
Attachment #700572 - Flags: review?(mark.finkle)
Attachment #700616 - Flags: review?(mark.finkle)
Attachment #700570 - Flags: review?(mark.finkle) → review+
Attachment #700616 - Flags: review?(mark.finkle) → review+
This should have gone in with the first patch. This removes the unused shadow.
Attachment #700640 - Flags: review?(mark.finkle)
Attached patch Part 4: GB iconsSplinter Review
These icons are for the "5+more" menu.
Attachment #700723 - Flags: review?(mark.finkle)
Attachment #700640 - Flags: review?(mark.finkle) → review+
Attachment #700723 - Flags: review?(mark.finkle) → review+
Comment on attachment 700570 [details] [diff] [review]
Part 1: Change the border

[Approval Request Comment]
Bug caused by (feature/regressing bug #): New Feature.
User impact if declined: Old tabs-switcher with orange highlight.
Testing completed (on m-c, etc.): Landed in m-c on 01/12
Risk to taking this patch (and alternatives if risky): Very low. This is just a theme change.
String or UUID changes made by this patch: -
Attachment #700570 - Flags: approval-mozilla-aurora?
Comment on attachment 700616 [details] [diff] [review]
Part 2: Replace private icons

[Approval Request Comment]
Bug caused by (feature/regressing bug #): New Feature.
User impact if declined: No new private-tab icon that's cute.
Testing completed (on m-c, etc.): Landed in m-c on 01/12
Risk to taking this patch (and alternatives if risky): Very low. Just image replacements.
String or UUID changes made by this patch: -
Attachment #700616 - Flags: approval-mozilla-aurora?
Comment on attachment 700640 [details] [diff] [review]
Part 3: Remove shadow

[Approval Request Comment]
Bug caused by (feature/regressing bug #): New Feature.
User impact if declined: None. Removing a redundant resource.
Testing completed (on m-c, etc.): Landed in m-c on 01/12
Risk to taking this patch (and alternatives if risky): None. Removing a redundant resource.
String or UUID changes made by this patch: -
Attachment #700640 - Flags: approval-mozilla-aurora?
Comment on attachment 700723 [details] [diff] [review]
Part 4: GB icons

[Approval Request Comment]
Bug caused by (feature/regressing bug #): New Feature.
User impact if declined: New private tab icons for GB phones.
Testing completed (on m-c, etc.): Landed in m-c on 01/12
Risk to taking this patch (and alternatives if risky): None. These are the GB comrades.
String or UUID changes made by this patch: -
Attachment #700723 - Flags: approval-mozilla-aurora?
Comment on attachment 700570 [details] [diff] [review]
Part 1: Change the border

Approving all the patches here considering they are low risk and are needed for private browsing feature landing in FF20 .
Attachment #700570 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Attachment #700616 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Attachment #700640 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Attachment #700723 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Private "add tab" button is changed on the latest Nightly.

Firefox for Android
Version: 21.0a1 (2013-01-23)
Device: Galaxy R
OS: Android 2.3.4
Verified fixed on Aurora 20.0a2 (2013-01-28)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.