Avoid hardcoded clientId in SafeBrowser.jsm

RESOLVED FIXED in mozilla21

Status

()

Toolkit
Safe Browsing
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: glandium, Assigned: glandium)

Tracking

unspecified
mozilla21
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

5 years ago
We currently have this in SafeBrowser.jsm:

#ifdef USE_HISTORIC_SAFEBROWSING_ID
    let clientID = "navclient-auto-ffox";
#else
    let clientID = Services.appinfo.name;
#endif

Building Firefox as a xulrunner application makes it having to choose between all xulrunner applications using the navclient-auto-ffox clientID, or Firefox using "firefox" as a clientID.

This also led mobile to add their own copy of the file just to do that:
#ifdef USE_HISTORIC_SAFEBROWSING_ID
    let clientID = "navclient-auto-ffox";
#else
#expand    let clientID = __MOZ_APP_UA_NAME__;
#endif

All in all, this would benefit from being handled with an app pref.
(Assignee)

Comment 1

5 years ago
Created attachment 698248 [details] [diff] [review]
Avoid hardcoded clientId in SafeBrowser.jsm
Attachment #698248 - Flags: review?(dtownsend+bugmail)
(Assignee)

Comment 2

5 years ago
Created attachment 698255 [details] [diff] [review]
Avoid hardcoded clientId in SafeBrowser.jsm
Attachment #698255 - Flags: review?(dtownsend+bugmail)
(Assignee)

Updated

5 years ago
Attachment #698248 - Attachment is obsolete: true
Attachment #698248 - Flags: review?(dtownsend+bugmail)
Attachment #698255 - Flags: review?(mark.finkle)
Attachment #698255 - Flags: review?(dtownsend+bugmail)
Attachment #698255 - Flags: review+
Comment on attachment 698255 [details] [diff] [review]
Avoid hardcoded clientId in SafeBrowser.jsm

Looks OK to me, but since we are removing the mobile SafeBrowsing component (which we wanted to do anyway) I want GCP to take a look too.
Attachment #698255 - Flags: review?(mark.finkle)
Attachment #698255 - Flags: review?(gpascutto)
Attachment #698255 - Flags: review+
Attachment #698255 - Flags: review?(gpascutto) → review+
(Assignee)

Comment 4

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/ff82d1a3955e

Comment 5

5 years ago
https://hg.mozilla.org/mozilla-central/rev/ff82d1a3955e
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla21
(Assignee)

Updated

5 years ago
Duplicate of this bug: 807559
Depends on: 830308
This bug causes a regression in reader mode, among other things, because the change breaks the mobile prefs file. See https://bugzilla.mozilla.org/show_bug.cgi?id=830308#c6 for details.
Backed out:
https://hg.mozilla.org/mozilla-central/rev/b72d2af170aa
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 9

5 years ago
Relanded with a fixup to mobile.js.
https://hg.mozilla.org/integration/mozilla-inbound/rev/d56a171a1325
https://hg.mozilla.org/mozilla-central/rev/d56a171a1325
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.