Closed Bug 827019 Opened 7 years ago Closed 7 years ago

404 error when using Chambers (UK) search

Categories

(Mozilla Localizations :: en-GB / English (United Kingdom), defect)

defect
Not set

Tracking

(firefox19 wontfix, firefox20 fixed)

RESOLVED FIXED
mozilla20
Tracking Status
firefox19 --- wontfix
firefox20 --- fixed

People

(Reporter: chrisccoulson, Assigned: iann_bugzilla)

References

Details

(Keywords: productization, qawanted)

Attachments

(2 files, 1 obsolete file)

Using the Chambers search from the search bar results in a 404 error, eg, a search for "Test" gives the following URL:

http://www.chambersharrap.co.uk/chambers/chref/chref.py/main?query=Test&title=21st&sourceid=Mozilla-search

Note that the following URL template does work:

http://www.chambers.co.uk/search.php?query={searchTerms}&title=21st&sourceid=Mozilla-search

This was originally reported at https://launchpad.net/bugs/1096286
As the next release is only days away, there won't be time to fix and get approval for the change.
Assignee: moz_en-gb → iann_bugzilla
Status: NEW → ASSIGNED
Attachment #698337 - Flags: review+
OS: Linux → All
Hardware: x86_64 → All
I will also need to find the correct person at Chambers (UK) to confirm they are happy this is correct and Mozilla can use the search engine.
Attachment #698339 - Flags: review?(moz_en-gb)
Comment on attachment 698337 [details] [diff] [review]
Temporarily remove chambers search plugin [Checked into beta: Comment 3]

http://hg.mozilla.org/releases/l10n/mozilla-beta/en-GB/rev/16601cf57598
This should make it into the upcoming Firefox 18
Attachment #698337 - Attachment description: Temporarily remove chambers search plugin → Temporarily remove chambers search plugin [Checked into beta: Comment 3]
Heads-up to release-mgmt...
Keywords: productization
This is not going to be in Firefox 18, as I've posted to .l10n, the last change date for that was back in December 24th.

I'm personally inclined to review a patch that removes chambers alltogether from aurora and then beta for 19. I'm not sure if we should keep a plugin that is either not used in any significant way, so chambers doesn't notice they're breaking something, or that chambers doesn't mind breaking without saying so upfront.
Guys, just one note: for any productization[1] changes, you'll need to ask for review from either me or Axel, and make sure not to push any changes upstream before you get an r+.

Anyhow, post-commit r+ on removing Chambers.

[1] https://wiki.mozilla.org/L10n:Firefox/Productization
(In reply to Axel Hecht [:Pike] from comment #5)
> 
> I'm personally inclined to review a patch that removes chambers alltogether
> from aurora and then beta for 19. I'm not sure if we should keep a plugin
> that is either not used in any significant way, so chambers doesn't notice
> they're breaking something, or that chambers doesn't mind breaking without
> saying so upfront.

Indeed, after doing a quick Google search I found this SUMO article from 4 months ago, so it looks like it has been broken for quite a long time already with hardly anybody noticing:

http://support.mozilla.org/en-US/questions/936287
(In reply to Chris Coulson from comment #7)
> (In reply to Axel Hecht [:Pike] from comment #5)
> > 
> > I'm personally inclined to review a patch that removes chambers alltogether
> > from aurora and then beta for 19. I'm not sure if we should keep a plugin
> > that is either not used in any significant way, so chambers doesn't notice
> > they're breaking something, or that chambers doesn't mind breaking without
> > saying so upfront.
> 
> Indeed, after doing a quick Google search I found this SUMO article from 4
> months ago, so it looks like it has been broken for quite a long time
> already with hardly anybody noticing:
> 
> http://support.mozilla.org/en-US/questions/936287

Depends what the en-GB user base is, I have no visibility of those figures, or how many people have been using the chambers' searchplugin (historically / currently).

en-GB is not offered automatically from IE or any other browser with OS/browser both being en-GB locale, so, if a user wants to switch from the shipped default, they get given Firefox en-US unless they know to click on "Systems & Languages". This will probably reduce the user base but not sure by how much.

Linux distributions do ship localised versions so, if the user updates the distribution, they do get the correct localised update.

Not sure what happens with Windows/OS X for en-GB on the release channel, but will see for Windows after next release.

The link in the article gives some working searchplugins:
http://mycroft.mozdev.org/search-engines.html?name=chambers
Should one of those be used? Is there a history available?
My main concern is that chambers didn't bother telling anyone that they changed their site.

I'm not concerned that en-GB users would be scarse per se (they're not, en-GB is one of our top-10 localizations), or that they wouldn't use non-default plugins as much as others (nobody but my mom does. honestly, my mom does.)
(In reply to Axel Hecht [:Pike] from comment #9)
> My main concern is that chambers didn't bother telling anyone that they
> changed their site.
I'd like to try and find out what contacts we have on both sides, as I guess there have been changes since the original plugin was created - would there have even been any sort of agreement and, if so, where/who would have had copies?
bug 348023 has some pointers to that.
Leo H added the following comment to Launchpad bug report 1096286:

As regards the idea of dropping Chambers from Firefox Search:

I feel that a reputable UK-English dictionary search engine such as Chambers is a valuable feature of Firefox.

Also, it is not only relevant to UK users of Firefox.  In many other countries where English is a second language, the interest in UK English, its spelling and usage, remains quite strong.  And many English language educational programmes worldwide require that students use a quality UK-English dictionary.

-- 
http://launchpad.net/bugs/1096286
From bug 348023, it was Mic who last dealt with this, ccing in case Mic knows updated contact details.
Depends on: 348023
Mic's not with mozilla for a while, any contacts she might have had are lost by now.
Attached patch Add back Chambers for en-GB (obsolete) — Splinter Review
I have been in contact with Chambers (part of Hodder Education now). I have confirmed with them that we are allowed to make use of their search engine through the search plugin and we are using the correct URL.
The current contact is:
Laura Vile
Marketing Executive
Hodder Consumer Learning
Tel: 0207 053 6766
Her email is of the form firstname.lastname at hoddereducation.co.uk
Attachment #712244 - Flags: review?(milos)
Comment on attachment 698339 [details] [diff] [review]
Fix chambers search plugin for FF19 and above [Checked in: Comment 27]

This is the patch for aurora, the other is for beta
Attachment #698339 - Flags: review?(moz_en-gb) → review?(milos)
If this is left unfixed for FF19 release, we'll be in the same position as FF18 release correct?
(In reply to Alex Keybl [:akeybl] from comment #17)
> If this is left unfixed for FF19 release, we'll be in the same position as
> FF18 release correct?

I don't believe anything landed in time for FF18, so FF18 had the 404, at the moment FF19 will have no Chambers search plugin.
(In reply to Ian Neal from comment #18)
> I don't believe anything landed in time for FF18, so FF18 had the 404, at
> the moment FF19 will have no Chambers search plugin.

No need to track in that case. Thanks for the context.
Comment on attachment 698339 [details] [diff] [review]
Fix chambers search plugin for FF19 and above [Checked in: Comment 27]

This is for FF20 and above.
Attachment #698339 - Flags: review?(axel)
Comment on attachment 712244 [details] [diff] [review]
Add back Chambers for en-GB

This is for FF19
Attachment #712244 - Flags: review?(axel)
Comment on attachment 712244 [details] [diff] [review]
Add back Chambers for en-GB

Sorry for the bugspam
Attachment #712244 - Attachment is obsolete: true
Attachment #712244 - Flags: review?(milos)
Attachment #712244 - Flags: review?(axel)
Attachment #698339 - Attachment description: Fix chambers search plugin → Fix chambers search plugin for FF19 and above
(In reply to Alex Keybl [:akeybl] from comment #19)
> (In reply to Ian Neal from comment #18)
> > I don't believe anything landed in time for FF18, so FF18 had the 404, at
> > the moment FF19 will have no Chambers search plugin.
> 
> No need to track in that case. Thanks for the context.

Sorry, I got confused. FF19 and above will have the 404
(In reply to Ian Neal from comment #23)
> (In reply to Alex Keybl [:akeybl] from comment #19)
> > (In reply to Ian Neal from comment #18)
> > > I don't believe anything landed in time for FF18, so FF18 had the 404, at
> > > the moment FF19 will have no Chambers search plugin.
> > 
> > No need to track in that case. Thanks for the context.
> 
> Sorry, I got confused. FF19 and above will have the 404

This is much too late to take a fix in FF19, unless absolutely critical. Can somebody please clarify:

* Expected behavior (search works)
* FF18's behavior (?)
* FF19's current behavior (sounds like 404)

If we are matching FF18's behavior (at least similarly), no action in FF19 will be taken at all.
Keywords: qawanted
(In reply to Alex Keybl [:akeybl] from comment #24)
> (In reply to Ian Neal from comment #23)
> > (In reply to Alex Keybl [:akeybl] from comment #19)
> > > (In reply to Ian Neal from comment #18)
> > > > I don't believe anything landed in time for FF18, so FF18 had the 404, at
> > > > the moment FF19 will have no Chambers search plugin.
> > > 
> > > No need to track in that case. Thanks for the context.
> > 
> > Sorry, I got confused. FF19 and above will have the 404
> 
> This is much too late to take a fix in FF19, unless absolutely critical. Can
> somebody please clarify:
> 
> * Expected behavior (search works)
Correct
> * FF18's behavior (?)
404
> * FF19's current behavior (sounds like 404)
404
> 
> If we are matching FF18's behavior (at least similarly), no action in FF19
> will be taken at all.
Marking as wont fix for FF19 then, and setting tracking? for FF20 - I don't want to miss another boat.
Comment on attachment 698339 [details] [diff] [review]
Fix chambers search plugin for FF19 and above [Checked in: Comment 27]

Review of attachment 698339 [details] [diff] [review]:
-----------------------------------------------------------------

r=me.

Please land on aurora with a check-in comment referencing this bug and my review, like "bug 827019, fix url in chambers search, r=l10n@mozilla.com".
Attachment #698339 - Flags: review?(milos)
Attachment #698339 - Flags: review?(axel)
Attachment #698339 - Flags: review+
Comment on attachment 698339 [details] [diff] [review]
Fix chambers search plugin for FF19 and above [Checked in: Comment 27]

http://hg.mozilla.org/releases/l10n/mozilla-aurora/en-GB/rev/26664edf2f65

Thanks
Attachment #698339 - Attachment description: Fix chambers search plugin for FF19 and above → Fix chambers search plugin for FF19 and above [Checked in: Comment 27]
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla20
You need to log in before you can comment on or make changes to this bug.