Closed Bug 827176 Opened 7 years ago Closed 7 years ago

java.lang.NullPointerException: at org.mozilla.gecko.GeckoInputConnection.notifyTextChange(GeckoInputConnection.java) at org.mozilla.gecko.GeckoInputConnection.endBatchEdit(GeckoInputConnection.java)

Categories

(Firefox for Android :: Keyboards and IME, defect, critical)

ARM
Android
defect
Not set
critical

Tracking

()

RESOLVED FIXED
Firefox 21
Tracking Status
firefox19 --- fixed
firefox20 --- fixed
firefox21 --- fixed

People

(Reporter: scoobidiver, Assigned: jchen)

References

Details

(Keywords: crash, Whiteboard: [native-crash])

Crash Data

Attachments

(1 file)

There are 9 crashes in 19.0a2 and 20.0a1.

Here is a crash report: bp-59379700-1357-47fa-a033-eaf3b2130103.

java.lang.NullPointerException
	at org.mozilla.gecko.GeckoInputConnection.notifyTextChange(GeckoInputConnection.java:260)
	at org.mozilla.gecko.GeckoInputConnection.endBatchEdit(GeckoInputConnection.java:88)
	at com.android.internal.view.IInputConnectionWrapper.executeMessage(IInputConnectionWrapper.java:400)
	at com.android.internal.view.IInputConnectionWrapper$MyHandler.handleMessage(IInputConnectionWrapper.java:77)
	at android.os.Handler.dispatchMessage(Handler.java:99)
	at android.os.Looper.loop(Looper.java:137)
	at android.app.ActivityThread.main(ActivityThread.java:4921)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:511)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:1038)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:805)
	at dalvik.system.NativeStart.main(Native Method)

More reports at:
https://crash-stats.mozilla.com/report/list?signature=java.lang.NullPointerException%3A+at+org.mozilla.gecko.GeckoInputConnection.notifyTextChange%28GeckoInputConnection.java%29
Assignee: nobody → nchen
Status: NEW → ASSIGNED
Comment on attachment 700672 [details] [diff] [review]
Properly reset GeckoInputConnection states during focus (v1)

Review of attachment 700672 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM, but maybe given the resetState() method a less generic name. It is a little confusing because it is NOT related to NOTIFY_IME_RESETINPUTSTATE.

\o/ for removing the last static variables in GeckoInputConnection! :D
Attachment #700672 - Flags: review?(cpeterson) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/118918b2774e

Leaving open for nom Aurora/Beta.
Component: General → Keyboards and IME
Flags: in-testsuite-
Whiteboard: [native-crash] → [native-crash][leave open]
Comment on attachment 700672 [details] [diff] [review]
Properly reset GeckoInputConnection states during focus (v1)

[Approval Request Comment]

Bug caused by (feature/regressing bug #): N/A

User impact if declined: Crash when changing input field focus

Testing completed (on m-c, etc.): Locally, m-c

Risk to taking this patch (and alternatives if risky): Very small; patch only performs clean up and does not introduce new functionality

String or UUID changes made by this patch: None
Attachment #700672 - Flags: approval-mozilla-beta?
Attachment #700672 - Flags: approval-mozilla-aurora?
Comment on attachment 700672 [details] [diff] [review]
Properly reset GeckoInputConnection states during focus (v1)

approving for branches, low risk and early in beta cycle.
Attachment #700672 - Flags: approval-mozilla-beta?
Attachment #700672 - Flags: approval-mozilla-beta+
Attachment #700672 - Flags: approval-mozilla-aurora?
Attachment #700672 - Flags: approval-mozilla-aurora+
Depends on: 829318
https://hg.mozilla.org/releases/mozilla-aurora/rev/dfc821302c6c

https://hg.mozilla.org/releases/mozilla-beta/rev/a8f593ceae74
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Whiteboard: [native-crash][leave open] → [native-crash]
Target Milestone: --- → Firefox 21
You need to log in before you can comment on or make changes to this bug.