Closed Bug 827265 Opened 7 years ago Closed 7 years ago

[toolbox] Command buttons have a left and right border on OS X when selected

Categories

(DevTools :: Framework, defect, P1)

x86
macOS
defect

Tracking

(firefox20 verified)

VERIFIED FIXED
Firefox 21
Tracking Status
firefox20 --- verified

People

(Reporter: vporof, Assigned: vporof)

References

Details

Attachments

(2 files, 1 obsolete file)

Attached image borders
Bug 827031 took care of the background, however the border remained on OS X.
Blocks: 816946
Priority: -- → P1
Attached patch v1 (obsolete) — Splinter Review
If the borders should be transparent, then this is enough.
Attachment #698607 - Flags: review?(paul)
Attached patch v2Splinter Review
This also works.
Assignee: nobody → vporof
Attachment #698607 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #698607 - Flags: review?(paul)
Attachment #698609 - Flags: review?(paul)
Attachment #698609 - Flags: review?(paul) → review+
Whiteboard: [land-in-fx-team]
https://hg.mozilla.org/integration/fx-team/rev/9306e34e7511

This will need an uplift to aurora.
Whiteboard: [land-in-fx-team] → [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/9306e34e7511
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 21
Comment on attachment 698609 [details] [diff] [review]
v2

[Approval Request Comment]
Bug caused by (feature/regressing bug #): new feature (toolbox)
User impact if declined: theme glitch
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): 0 (one CSS line)
String or UUID changes made by this patch: no
Attachment #698609 - Flags: approval-mozilla-aurora?
Attachment #698609 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Whiteboard: [land-in-aurora]
Whiteboard: [land-in-aurora]
Verified as fixed on the latest Nightly and Aurora - there are no right and left borders for the command buttons. 

Verified on Windows 7, Ubuntu 12.10 and Mac OS X 10.8.2:
Mozilla/5.0 (Windows NT 6.1; rv:21.0) Gecko/20130210 Firefox/21.0 (20130210031150)
Mozilla/5.0 (Windows NT 6.1; rv:20.0) Gecko/20130210 Firefox/20.0 (20130210042017)

Mozilla/5.0 (X11; Linux i686; rv:21.0) Gecko/20130211 Firefox/21.0 (20130211031055)
Mozilla/5.0 (X11; Linux i686; rv:20.0) Gecko/20130210 Firefox/20.0 (20130210042017)

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:21.0) Gecko/20130211 Firefox/21.0 (20130211031055)
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:20.0) Gecko/20130211 Firefox/20.0 (20130211042016)
Status: RESOLVED → VERIFIED
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.