Avoid useless onVisit work on the transition filtered queries

RESOLVED FIXED in Firefox 20

Status

()

defect
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: mak, Assigned: mak)

Tracking

Trunk
mozilla21
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox19 unaffected, firefox20 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

if we get an onVisit notification in a query filtering by transition, we can avoid doing anything if the transitions don't match.
Summary: Avoid useless onVisit refreshes of the transition searches → Avoid useless onVisit work on the transition filtered queries
Keywords: meta
Keywords: meta
Posted patch patch v1.0 (obsolete) — Splinter Review
this should solve the hangs when navigating with the Library Downloads view open.

The live update is already tested in test_transitions.js
Attachment #698677 - Flags: review?(mano)
Flags: in-testsuite+
What was the reason transition-queries were made COMPLEX in the first place?
(In reply to Mano from comment #2)
> What was the reason transition-queries were made COMPLEX in the first place?

When Mehdi implemented that filter EvaluateQueryForNode was unpolished and in a somehow bogus state (I think we also still had the old and heavy FilterResultSet implementation), my recent cleanups in that method for hidden and frecency made clear we could support more simple results updating, indeed it should have not been complex in the first place, but at that time was easier to do ("just refresh and everything will work").
https://hg.mozilla.org/integration/mozilla-inbound/rev/33b1a42588c2

should be ported to Aurora.
Target Milestone: --- → mozilla21
Backed out for breaking xpcshell:
https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=30ec18652409&jobname=xpcshell
(is push after since yours got coalesced)

https://hg.mozilla.org/integration/mozilla-inbound/rev/f7947681f3fa

Please consider using Try if possible :-)
interesting, I ran all tests locally before pushing, wonder what happened
Posted patch patch v1.1Splinter Review
the usual last minute change, let's avoid assigning -1 to an uint!
Attachment #698677 - Attachment is obsolete: true
https://hg.mozilla.org/mozilla-central/rev/63cbf8539eac
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Comment on attachment 699265 [details] [diff] [review]
patch v1.1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Downloads panel feature
User impact if declined: Performance issues
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): involves just the download query
String or UUID changes made by this patch: none
Attachment #699265 - Flags: approval-mozilla-aurora?
Attachment #699265 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Depends on: 835446
You need to log in before you can comment on or make changes to this bug.