All users were logged out of Bugzilla on October 13th, 2018

[Volume] - Unlock screen sound unaffected by mute system volume

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: aaronmt, Assigned: mihai)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-basecamp:-, b2g18+ affected, b2g18-v1.0.1 affected)

Details

(Whiteboard: interaction, UX-p2)

(Reporter)

Description

6 years ago
Currently when one mutes the device system volume and attempts to, at a further time, unlock the device (with lock-sound enabled), the device will still emit a high-volume sound-clip.

Device unlock is unaffected by system audio mute.

--
Unagi-b2g18 (01/07)
(Reporter)

Updated

6 years ago
status-b2g18: --- → affected
blocking-basecamp: ? → -
tracking-b2g18: --- → +

Updated

6 years ago
blocking-basecamp: - → ?
tracking-b2g18: + → ---
Whiteboard: interaction, UX-p2
blocking-basecamp: ? → -
tracking-b2g18: --- → +
Batch edit: Bugs marked status-b2g18: affected after 2/13 branching of v1.0.1 are now also status-b2g18-v1.0.1: affected
status-b2g18-v1.0.1: --- → affected
(Assignee)

Updated

6 years ago
Depends on: 819842
From what I noticed in lockscreen.js, the unlock sound is not registered with any audio channel type (cf. https://github.com/mozilla-b2g/gaia/blob/master/apps/system/js/lockscreen.js#L563) and this might be the first issue in adjusting its volume.

Additionally, might be the case that the fix for bug 819842 will solve this, as long as the audio channel type is correctly set (to 'notification' I assume).

Alive, can you confirm on this? Bug 837477 seems to be within the same scope (i.e. making use of the correct audio channel type -- 'notification') and its fix was merged already.
Assignee: nobody → mihai
Flags: needinfo?(alive)
(In reply to Mihai Cirlanaru [:mcirlanaru] from comment #2)
> From what I noticed in lockscreen.js, the unlock sound is not registered
> with any audio channel type (cf.
> https://github.com/mozilla-b2g/gaia/blob/master/apps/system/js/lockscreen.
> js#L563) and this might be the first issue in adjusting its volume.

The default audio channel for audio element is normal, however the default channel we adjust using volume rockers is notification. I would say this is by design, but yes, it's not perfect so we're having many sound bugs relevant to silent the phone but not silent the channel you want it to be muted.

> 
> Additionally, might be the case that the fix for bug 819842 will solve this,
> as long as the audio channel type is correctly set (to 'notification' I
> assume).

I don't think the unlock sound is a notification.
So the workaround is just bug 819842, you're right. The strategy is to silent "notification/ringer" and "content/normal" at the same time.
Flags: needinfo?(alive)
This was solved by the patch for bug 819842, marking it as RESOLVED > WORKSFORME.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
No longer depends on: 819842
You need to log in before you can comment on or make changes to this bug.