Closed Bug 827508 Opened 8 years ago Closed 8 years ago

Upload packages needed by Marionette to puppetagain

Categories

(Release Engineering :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: jgriffin, Unassigned)

References

Details

In order to make the Marionette mozharness scripts less fragile to changes in mozbase dependencies, we're going to switch to install them from puppetagain, instead of tests.zip.

In order for this to happen, we'll first have to upload all the packages needed by Marionette to puppetagain.  To start with, we should probably use the versions that already exist in m-c.  These are:

ManifestDestiny-0.5.6: http://pypi.python.org/packages/source/M/ManifestDestiny/ManifestDestiny-0.5.6.tar.gz#md5=c9d218ad58c93c170c65a43ab916dd6d

mozhttpd-0.5 (already present)

mozinfo-0.4 (already present)

mozprocess-0.8 (already present)

mozrunner-5.14 http://pypi.python.org/packages/source/m/mozrunner/mozrunner-5.14.tar.gz#md5=3b7f7bd750fb8d059b60caa20cc31b6f

mozdevice-0.18 http://pypi.python.org/packages/source/m/mozdevice/mozdevice-0.18.tar.gz#md5=d02e4f488fa00e8698c10b06234b18e2

mozfile-0.2 http://pypi.python.org/packages/source/m/mozfile/mozfile-0.2.tar.gz#md5=db237789b76859a139ec3bd1f03721be

mozprofile-0.4 http://pypi.python.org/packages/source/m/mozprofile/mozprofile-0.4.tar.gz#md5=90d84cfd27b51a069c7fd756816adcc0

After these are uploaded to puppetagain, I'll make a patch to the mozharness scripts to use them instead of install mozbase packages from tests.zip.
Uploaded.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Blocks: 827531
Product: mozilla.org → Release Engineering
Component: General Automation → General
You need to log in before you can comment on or make changes to this bug.