If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

lancenet.com.br doesn't recognize B2G UA as mobile

VERIFIED FIXED

Status

Tech Evangelism
Mobile
VERIFIED FIXED
5 years ago
3 years ago

People

(Reporter: lmandel, Assigned: karlcow)

Tracking

(Depends on: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [uaoverride] [country-br] [serversniff][sitewait], URL)

lancenet.com.br serves a desktop site to B2G. Bug 819210 added an UA override for this domain. The override should be removed once the domain serves mobile content to B2G. This bug tracks the evangelism for the site to recognize the B2G UA and the removal of the override at that time.
Blocks: 827569
Whiteboard: [uaoverride]
(Assignee)

Updated

4 years ago
Whiteboard: [uaoverride] → [uaoverride] [country-br]
(Assignee)

Comment 1

4 years ago
Server side user agent detection with redirection to a mobile domain.
Needs to be contacted.


#Firefox for Android

GET / HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate, compress
Host: www.lancenet.com.br
User-Agent: Mozilla/5.0 (Android; Mobile; rv:18.0) Gecko/18.0 Firefox/18.0

HTTP/1.1 302 Moved Temporarily
Connection: keep-alive
Content-Length: 161
Content-Type: text/html
Date: Thu, 15 Aug 2013 19:42:22 GMT
Location: http://m.lancenet.com.br/
Server: nginx/0.7.67


GET / HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate, compress
Host: m.lancenet.com.br
User-Agent: Mozilla/5.0 (Android; Mobile; rv:18.0) Gecko/18.0 Firefox/18.0

HTTP/1.1 302 Found
Cache-Control: max-age=1, private, must-revalidate
Connection: close
Content-Encoding: gzip
Content-Length: 20
Content-Type: text/html
Date: Thu, 15 Aug 2013 22:05:11 GMT
Expires: Thu, 15 Aug 2013 22:06:11 GMT
Server: Apache/2.2.16 (Debian)
Vary: Accept-Encoding
X-Powered-By: PHP/5.3.3-7+squeeze9
location: /mobile/

GET /mobile/ HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate, compress
Host: m.lancenet.com.br
User-Agent: Mozilla/5.0 (Android; Mobile; rv:18.0) Gecko/18.0 Firefox/18.0

HTTP/1.1 200 OK
Cache-Control: max-age=1, private, must-revalidate
Connection: close
Content-Encoding: gzip
Content-Length: 5410
Content-Type: text/html
Date: Thu, 15 Aug 2013 22:05:41 GMT
Expires: Thu, 15 Aug 2013 22:06:41 GMT
Server: Apache/2.2.16 (Debian)
Vary: Accept-Encoding
X-Powered-By: PHP/5.3.3-7+squeeze9



#Firefox OS

GET / HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate, compress
Host: www.lancenet.com.br
User-Agent: Mozilla/5.0 (Mobile; rv:18.0) Gecko/18.0 Firefox/18.0

HTTP/1.1 200 OK
Accept-Ranges: bytes
Cache-Control: max-age=0, no-cache, no-store, must-revalidate
Connection: keep-alive
Content-Encoding: gzip
Content-Length: 18417
Content-Type: text/html; charset=UTF-8
Date: Thu, 15 Aug 2013 19:42:11 GMT
Expires: Thu, 01 Dec 1994 00:00:00 GMT
Pragma: no-cache
Server: nginx/0.7.67
Vary: Accept-Encoding,User-Agent
X-Filmed-By: Filmed by Lemonhead
Assignee: nobody → kdubost
Whiteboard: [uaoverride] [country-br] → [uaoverride] [country-br] [serversniff]
(Assignee)

Updated

4 years ago
Assignee: kdubost → nobody
Whiteboard: [uaoverride] [country-br] [serversniff] → [uaoverride] [country-br] [serversniff][contactready]
(Assignee)

Updated

4 years ago
(Assignee)

Updated

4 years ago
(Assignee)

Comment 2

4 years ago
The Mobile site is http://m.lancenet.com.br/mobile/
Contacting through twitter will not lead to anything good. The account is just a bot.
Maybe a possibility

webmaster@lancenet.com.br

Also "Working at Diário Lance!"
http://www.slideshare.net/AlessandroAbate
https://twitter.com/Aleabate

Let's try
http://twitter.com/MozWebCompat/status/423719727752413184
Assignee: nobody → kdubost
Status: NEW → ASSIGNED
Whiteboard: [uaoverride] [country-br] [serversniff][contactready] → [uaoverride] [country-br] [serversniff][sitewait]
(Assignee)

Updated

4 years ago
Depends on: 974271
(Assignee)

Comment 3

4 years ago
So the Web site is powered by the tech from [Bitban technologies][1]
[1]: http://www.bitban.com/

I might be possible that bitban handles the user agent detection.
I created a new bug 974271

Comment 4

4 years ago
Hello, Bitban Techonolgies developed the CMS that those sites uses (and a few journal websites around the world). However, the hosting depends on the journal site. In the case of Lancenet, its hosted here in Brazil.

The issue is, Firefox in Android is redirecting to mobile website but Firefox OS don't, right? I'm contacting them to resolve this.
(Assignee)

Comment 5

4 years ago
Thanks a lot leo!
Automated test thinks this is fixed (I agree!). Verify and remove UA override?
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 7

4 years ago
Excellent this is working. Thanks Leo. I will remove the UA override.
(Assignee)

Updated

4 years ago
Blocks: 965060

Comment 8

4 years ago
I'm glad I could help! =D
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.