Design Tweaks For Mixed Content Blocker Doorhanger

RESOLVED DUPLICATE of bug 834828

Status

()

RESOLVED DUPLICATE of bug 834828
6 years ago
a year ago

People

(Reporter: tanvi, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Comment hidden (empty)
(Reporter)

Comment 1

6 years ago
The original design for the Mixed Content Blocker can be found here http://people.mozilla.com/~lco/ProjectSPF/Mixed_Content/Mixed_Content_Spec/.

There has been some discussion about:
* the "More Info" button
* one-tone vs two-tone styling
* text
* Choices at the bottom of the doorhanger (Keep Blocking, Disable protection on this page, Not Now)

Opening this bug to continue the discussion.

I cloned bug 822371, so please remove yourself from the cc if you are not interested in this bug.  Thanks!

Comment 2

6 years ago
With regards to the text, I've placed some suggestions for discussion at https://firefox-ux.etherpad.mozilla.org/MixedContent-messages

I'll ping Matej and see if he can help us come up with something we can be happy with.

Comment 3

6 years ago
Responding to some of Dolske's comments in bug 822371 : https://bugzilla.mozilla.org/show_bug.cgi?id=822371#c32

(In reply to Justin Dolske [:Dolske] from comment #32)
> Just some brief comments:
> 
> (In reply to Larissa Co from comment #31)
> 
> > 1. Expanding doorhanger design
> > 
> > The reason why we show a shorter message first then allow the user to expand
> > that message is [...]
> 
> Is this still relevant with the prompt not being shown by default? The user
> has to take explicit action to show it...

Good point, I'm ok with removing the shorter message (at least for now. We might not even need to show it in the future if the icon is good enough for most people who care about it.)


> 
> > 2. Expanded doorhanger text
> > 
> > [...]
> > I organized it this way because it's first important to give the impression
> > that we are protecting the user above everything else. Next, it's important
> > to respect the user's task and explain how our protection impacts them.
> 
> Somewhere in here I want to make sure we've considered consistency with
> other similar UI. We've got quite a few of them, and there's a cost (in user
> terms) to having differences.

Yes, I'll make sure to keep this in mind. I'll ask the UX team in our meeting tomorrow about what they think too.

> 
> > 4. Button choices
> > 
> > I'm not sure what the "Not Now" button actually does. Since protection is on
> > by default and the door hanger doesn't appear all the time anyway, I would
> > remove this option. 
> 
> All doorhangers get this. It does nothing, and is provided so users who feel
> compelled to make a choice have a harmless way out.

I'm not sold on this, but we can keep it in for consistency. I just worry that more choices will confuse the user. When the choice is a dichotomy between "continue blocking" and "disable protection", it's easier to make that choice.
(Reporter)

Comment 4

6 years ago
Can we find a way for the doorhanger to persist if the user selects "Not Now"?  Right now, if the user selects "Not Now" the doorhanger disappears and the user can't change their mind later (and hence "Not Now" is equivalent to "Keep Blocking").

If this is a simple code change, I am happy to make it, but need some guidance on how to do it.  Thanks!
(In reply to Tanvi Vyas [:tanvi] from comment #4)
> Can we find a way for the doorhanger to persist if the user selects "Not
> Now"?  Right now, if the user selects "Not Now" the doorhanger disappears
> and the user can't change their mind later (and hence "Not Now" is
> equivalent to "Keep Blocking").

PopupNotifications default behavior is to stay "dismissed" (collapsed, but re-openable from the location bar icon) after choosing "Not Now". Since you don't specify removeOnDismissal or an eventCallback in the call to PopupNotifications.show(), I don't understand why it would be disappearing after choosing "not now".

Comment 6

6 years ago
I just clicked "Not Now" on 23.0a1 (2013-04-11) from https://air.mozilla.org/poetic-apis/ and the icon goes away from the location bar. This is different than what was mentioned in the blog post:

"If a user decides to “Keep Blocking” or selects “Not Now”, the notification in the location bar will disappear:"
https://blog.mozilla.org/tanvi/2013/04/10/mixed-content-blocking-enabled-in-firefox-23/

Comment 7

6 years ago
(In reply to Edward Lee :Mardak from comment #6)
> I just clicked "Not Now" and the icon goes away from the location bar
Wow. I need to re-read a third time before posting. The icon does *NOT* go away after clicking "Not Now" for me.
(Reporter)

Comment 8

6 years ago
(In reply to Edward Lee :Mardak from comment #7)
> (In reply to Edward Lee :Mardak from comment #6)
> > I just clicked "Not Now" and the icon goes away from the location bar
> Wow. I need to re-read a third time before posting. The icon does *NOT* go
> away after clicking "Not Now" for me.

Ah you are right!  Not sure when that changed; perhaps with another patch to PopupNotifications, since I probably haven't tested the "Not Now" functionality in a while.  I will update the blog post.
See also bug 862201 -- the icon disappears after clicking "Keep Blocking".
(Reporter)

Updated

6 years ago
Depends on: 803620
(Reporter)

Updated

6 years ago
No longer depends on: 803620
(Reporter)

Comment 10

6 years ago
I think we can close this bug or mark is as a duplicate of bug 834828.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 834828
You need to log in before you can comment on or make changes to this bug.