Closed Bug 827668 Opened 9 years ago Closed 8 years ago

scribd.com doesn't recognize B2G UA as mobile

Categories

(Web Compatibility :: Mobile, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: lmandel, Assigned: karlcow)

References

()

Details

(Whiteboard: [uaoverride] [serversniff] [sitewait] [country-all])

scribd.com serves a desktop site to B2G. Bug 819210 added an UA override for this domain. The override should be removed once the domain serves mobile content to B2G. This bug tracks the evangelism for the site to recognize the B2G UA and the removal of the override at that time.
Blocks: scribd.com
Whiteboard: [uaoverride]
With UA override on ZTE device (Firefox OS)

http://scribd.com/ redirects to http://www.scribd.com/mobile
The mobile site is working well.

Without UA override on ZTE device (Firefox OS)
http://scribd.com/ redirects to http://www.scribd.com/
The desktop site is displayed.


# HTTP SIDE 

with Firefox Android

GET / HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate, compress
Host: www.scribd.com
User-Agent: Mozilla/5.0 (Android; Mobile; rv:18.0) Gecko/18.0 Firefox/18.0



HTTP/1.1 302 Found
Cache-Control: no-cache
Connection: keep-alive
Content-Length: 94
Content-Type: text/html; charset=utf-8
Date: Wed, 31 Jul 2013 17:05:03 GMT
Location: http://www.scribd.com/mobile
Server: nginx/1.2.9
Set-Cookie: scribd_ubtc=u%3D43d5f990-dc31-0130-ba4c-0025902de78c%26h%3DNVPLboMNrdnegQodQR2%2F2DSmyWuE9MhkfLYTwq9amIc%3D; domain=.scribd.com; path=/; expires=Mon, 31 Jul 2028 17:05:03 GMT
Set-Cookie: _scribd_session=BAh7BiIKZmxhc2hJQzonQWN0aW9uQ29udHJvbGxlcjo6Rmxhc2g6OkZsYXNoSGFzaHsABjoKQHVzZWR7AA%3D%3D--fc7b6c3069b12443693a170a61dfab07795a4030; domain=.scribd.com; path=/; expires=Fri, 01 Jan 2016 00:00:00 GMT; HttpOnly
Status: 302 Found
Vary: X-Language-Locale
X-Debug: Homepage with no cache
X-Runtime: 3ms

<html><body>You are being <a href="http://www.scribd.com/mobile">redirected</a>.</body></html>

with Firefox OS

GET / HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate, compress
Host: www.scribd.com
User-Agent: Mozilla/5.0 (Mobile; rv:18.0) Gecko/18.0 Firefox/18.0



HTTP/1.1 200 OK
Age: 265
Cache-Control: no-cache
Connection: keep-alive
Content-Encoding: gzip
Content-Type: text/html; charset=utf-8
Date: Wed, 31 Jul 2013 17:06:14 GMT
Expires: Wed, 31 Jul 2013 17:06:13 GMT
Server: nginx/1.2.9
Status: 200 OK
Transfer-Encoding: chunked
Vary: Accept-Encoding
Via: 1.1 squid02:3128 (squid)
X-Cache: HIT from squid02
X-Debug: Homepage with squid
X-Frame-Options: SAMEORIGIN
X-Runtime: 3263ms

<!DOCTYPE HTML><html lang="en" xml:lang="en" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://www.facebook.com/2008/fbml" xmlns:og="http://opengraphprotocol.org/schema/"><head prefix="og: http://ogp.me/ns# scribd-com: http://ogp.me/ns/apps/scribd-com#"><!--


Redirection is happening server side with a change of the URL.
Assignee: nobody → kdubost
Whiteboard: [uaoverride] → [uaoverride] [serversniff]
contacted through their support@scribd.com email.
Whiteboard: [uaoverride] [serversniff] → [uaoverride] [serversniff] [sitewait]
Your request has been received and has the unique ID number #319997.
They acknowledged the contact, I will explain in their ticket.

> Hello Karl,
> 
> Thank you for reporting this issue to us. I reviewed the bug and it seems that www.scribd.com/mobile is not displaying in Firefox OS, it displays the non-mobile version?
> 
> Please let me know your question and I will pass it along to our engineering department.
> 
> Best regards,
> K*** J***
> Scribd, Inc.
Sent this to scribd

Hi K****,

Thanks a lot for replying.
So the details of the bugs are explained at https://bugzilla.mozilla.org/show_bug.cgi?id=827668

Summary:

Firefox OS should receive the mobile version of the site.


* When entering http://www.scribd.com/ in "Firefox for Android", scribd redirects to http://www.scribd.com/mobile
  Firefox Android UA 
  "Mozilla/5.0 (Android; Mobile; rv:18.0) Gecko/18.0 Firefox/18.0"


* When entering http://www.scribd.com/ in "Firefox OS", scribd stays on the desktop site.
  Firefox OS UA
  "Mozilla/5.0 (Mobile; rv:18.0) Gecko/18.0 Firefox/18.0"


Firefox OS is installed on mobile devices and should receive the mobile version of the Web site in absence of a Web site with features detection and responsive design.

Thanks a lot for sending it to the engineering department.
Ah! We got pushback. :)

> Hello Karl,
> 
> I have passed along the information to the engineers in charge of Android devices. He said we do not officially support Firefox OS, but he will take a look at the bug if he has time.
> 
> Best regards,
> K*** J****
> Scribd, Inc.

I replied that I already tested with the UA override and that it was working. 

> Hi K****,
> 
> Thanks. I have tested the site on Firefox OS with UA override and it's working well. :)
> So it is working ;) It is just a matter of UA detection. 
> 
> I will fill the bug with your answer.
> Thanks.

So we will need to find a better way to reach them out.
Whiteboard: [uaoverride] [serversniff] [sitewait] → [uaoverride] [serversniff] [sitewait] [country-all]
The last message I have received from scribd was 

> Your request (#319997) has been updated and marked resolved; please see the comments below. To add a comment and reopen the ticket, reply to this email and include your reply above the indicated line, or follow this link:
> 
> http://support.scribd.com/tickets/319997

I'm trying to contact them again.
They are now referring to  http://support.scribd.com/tickets/335059 for the ticket.
To my question asking for the status… I got the same answer

>Your request (#335059) has been updated and marked resolved; please see the comments below. To add a comment and reopen the ticket, reply to this email and include your reply above the indicated line, or follow this link:
>
> http://support.scribd.com/tickets/335059
> 
> Support Request Summary:
>
>	
> K**** J**** (Support Desk)
> Sep 06 11:35 am (PDT)
>
> Thank you for the update.
> 
> Best regards,
> K**** J****
> Scribd, Inc.

I think there is a no dialog going on.
Not sure what to do with it.

If someone knows a person in the engineering team at scribd. That would be useful. At least to understand what is the issue they are facing.
Status: NEW → ASSIGNED
I'm tempted to closed this one as WONTFIX. Scribd is not ready to listen yet.
Jishnu - LinkedIn tells me that you have a number of contacts at Scribd. Can you please help out with an introduction to someone who you think can help get Scribd to serve mobile content to Firefox OS? Thanks!
Flags: needinfo?(jmenon)
The issue is still not solved.
We need to find someone behind the user support wall. 
The site is working with Firefox OS when receiving the mobile version, it's really just a question of User Agent detection.
Hey guys. I work at Scribd on the front-end team. As some of you figured out, this is user agent detection missing out this specific case.

I can make a fix for this and get it deployed for this week, but since I am not familiar with Firefox OS or have a device for it, please confirm me that

"Mozilla/5.0 (Mobile; rv:18.0) Gecko/18.0 Firefox/18.0" is the expected User Agent in Firefox OS browser

Any other information or recommendation about this topic is welcome! 
After this fix is deployed and tested personally, I will comment back on the ticket for someone else to test it and close it.
Hi Gabriel,

Thanks a lot for stepping in. 
The user agent has two forms

"Mozilla/5.0 (Mobile; rv:$VERSION) Gecko/$VERSION Firefox/$VERSION"
and 
"Mozilla/5.0 (Mobile; nnnn; rv:$VERSION) Gecko/$VERSION Firefox/$VERSION"

where nnnn might be a device_Id string. Mozilla does not recommend the nnnn but some device makers/OEM might go ahead with it.

For identification we usually recommend to match i/mobi/ and then exclude ipad (which as mobi too). The why is that we want to maximize for others too, not only for Firefox. For sure, adopt the strategy which is suitable with your environment. 

Usually the User Agent Strings patterns are documented at 
https://developer.mozilla.org/en-US/docs/Gecko_user_agent_string_reference#Firefox_OS

Hope it helps, tell me if you need more info.
Flags: needinfo?(jmenon) → needinfo?(gabriel)
Sent a reminder by mail to Gabriel (here) in the comments.
Thanks for the reminder. I have pushed some changes and will verify them after they are deployed to the production servers. Will post back if they work for me.
Flags: needinfo?(gabriel)
Hey Guys, deployed and tested. Confirm. Im checking the user agent to have /mobi/i and Firefox.
Monday morning in Japan. Just tested on Firefox OS after erasing Cookies and Cache.
and… drumroll… it is working!

Thanks Gabriel. That is a very big win for the community as large. Excellent!
http://twitter.com/MozWebCompat/status/427590030584868864
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Blocks: 948642
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.